Somme.si.ens .... mais pour du texte

Bonjour tous,
il y a quelques temps vous m’aviez fortement dépanné pour élaborer une formule de recherche dans un tableau plutôt complexe qui me permettait de référencer les numéros d’équipe de chacun de mes salariés… de 1 à 8 équipes… (colonne C)
Aujourd’hui, je souhaite ajouter les références « CP », RTT, REPOS etc etc, dans cette même colonne… mais logiquement la fonction SOMME.SI.ENS ne fonctionne pas…

=SOMME.SI.ENS($C:$C;$B:$B;V111;DECALER($F:$F;0;MAX(0;W74-1));$W$110)

Alors… comment la faire évoluer pour que mon « tableau des absences » (V146:AJ178) affiche les bons motifs?..
Pour ma part je pensais partir du « tableau des présences » (V2:AJ33) et faire en sorte de chercher le motif quand la cellule d’un installateur est « 0 »…
je renseigne cette formule en W148 par exemple =SI(W3=0;RECHERCHEV($W$147;F10:N14;9);"") ca ne fonctionne pas à tous les coups…

J’espère ne pas être trop confus dans mon explication et reste à votre totale écoute …
bonne soirée à tous.
fabrice

comment joindre le fichier ?équipes et présence par jour.xlsx (284,9 Ko)

Bonjour
image