Recherche + somme sur une valeur recherche donnant plusieurs resultats

Bonjour,

Voici mon fichier Excel. Mon but est de mettre une formule en cellule B5 (feuille BILAN) pour obtenir la somme des soldes débits colonne C (N-2 = 2018) des comptes commençant par « 20 » de la feuille BALANCE !

Après j’aimerai y rajouter une soustraction d’une somme des montants au crédit colonne D (N-2 = 2018) pour les comptes commençant par « 280 » de la feuille BALANCE.

Le résultat à obtenir en cellule B5 de la feuille BILAN est : 46 999,19 , soit (675+62228.91-347.5-15557.22).
Idem pour les années 2019 (cellule D5) et 2020 (cellule F5) de la feuille BILAN.

J’ai besoin de cette formule car la base de donnée « feuille BALANCE » peut changer en fonction de mes dossiers donc il peut y avoir plus de ligne, plus de comptes, plusieurs déclinaisons etc …

Fichier joint
comptabilité.xlsx (22,1 Ko)

Merci pour votre aide.

Bonsoir,
Une proposition à adapter suivant les lignes.
=SOMMEPROD((GAUCHE(BALANCE!A3:A23;2)=« 20 »)(BALANCE!C3:C23))-SOMMEPROD((GAUCHE(BALANCE!A3:A23;3)=« 280 »)(BALANCE!D3:D23))
Cordialement.