Quand cellule date vide (avec formule) un petit texte reste visible

Bonjour à tous
J’ai une formule qui fonctionne très bien, ce n’est pas moi qui l’ai faite (Cow 18) car trop complexe pour moi.
En A24 dans la formule ci-dessous, cela est une cellule qui donne une date. Depuis hier j’ai ajouté une formule dans cette même cellule pour avoir la date automatiquement via une certaine durée.
Et maintenant que cette cellule A24 n’est plus vide car il y a une formule, j’ai ce texte
“ : = 0 km “ au lieu d’avoir du vide car le tableau n’est pas remplie à cette date là en A24

Je n’arrive pas à éviter d’avoir ce petit texte dans la lecture de cette formule sur ma feuille principale de mon fichier. Voir capture d’écran

=SI(ESTNUM(CHERCHE("journee";A24));A24;SI(ET(ESTNUM(CHERCHE("journee";A22));NBVAL(A24:B24)=2);TEXTE(A24;"jjj jj/mm")& " : " &  B24 &
 CONCAT(SI(D24:D30<>"";" -> "&D24:D30;"")) & " = " & F22 & " km"; ""))

Ci dessous la formule pour la date que j’ai en A24; J’ai essayé plusieurs formules mais à chaque fois j’ai le même problème
Merci d’avance pour votre aide

=SI($N$24=0;"";$E$22)

J’ai encore changé la formule en A24 mais toujours le même problème

=SI($E$9>A15;A15+1;"")

J’ai trouvé une solution merci à tous Bonne journée

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.