Probleme fonction SI

bonjour à tous
j’ai un petit soucis avec la fonction SI
je m’explique avec une image


ma formule est la suivante :
=SI(B1="";"";SI(ET(B1=L1;C1=M1);3;SI(SIGNE(B1-C1)=SIGNE(L1-M1);1;0)))
pourquoi en N j’ai 1 alors que les cellules L et M sont vide ?
merci de m’avoir lu et pour vos réponses

Bonjour toffduq, ça faisait longtemps :stuck_out_tongue:

Parce que SIGNE() renvoi une valeur même si les cellules sont vides, Excel les prends comme des 0

Il faut donc ajouter un test

@+

salut oui ca faisais un moment que j’était pas passer sur le forum
et merci pour ta solution
ca fonctionne
a bientot :wink:

1 J'aime