Nombre de jours réalisés par personne sachant que chaque personne réalise plusieurs taches par jour

Bonjour à tous,
Tout nouveau sur le forum, je cherche une fonction qui me permette de calculer automatiquement le nombre de jours réalisés par chaque personne sachant que chaque personne peut réaliser une à plusieurs taches chaque jour.

Date Personne Taches
01/06/2017 A Tennis
01/06/2017 B Rugby
01/06/2017 C Tennis
01/06/2017 C Rugby
01/06/2017 A Football
01/06/2017 D Football
01/06/2017 E Rugby
01/06/2017 B Basket
02/06/2017 D Tennis
02/06/2017 B Rugby
02/06/2017 E Tennis
02/06/2017 E Football
02/06/2017 C Rugby
02/06/2017 C Tennis
02/06/2017 A Tennis
02/06/2017 D Tennis
02/06/2017 A Football
02/06/2017 E Football
03/06/2017 B Tennis
03/06/2017 C Rugby
04/06/2017 A Tennis
04/06/2017 A Rugby
04/06/2017 A Football

J’aimerais une formule qui me permettre d’atteindre ce résultat :
Personne Nombre de jours d’activité
A 3
B 3
C 3
D 2
E 2
F 0

D’avance merci à tous !

Bonjour
Peux tu ajouter le fichier stp?

Bonjour,

Voici un exemple de fichier.

J’espère sincèrement que vous trouverez une solution.

D’avance merci.

Exemple fichier 2.xlsx (15.9 KB)

Bonjour
Dans ton cas, tu souhaites compter le nombre de valeurs uniques qui respectent une condition particulière.

Dans un premier temps je te propose de rajouter une colonne fréquence qui a chaque valeur va attribuer un coefficient afin de diminuer le poids des valeurs qui apparaissent plusieurs fois.
Concrètement, si une combinaison de date et de personnes apparaît 4 fois, on attribue à chaque apparition un poids de 1/4

La formule pour calculer ce poids est : =1/NB.SI.ENS(A:A;A2;B:B;B2)

Dans un 2e temps pour connaitre le nombre de valeurs uniques qui respectent une condition, il suffit de sommer la colonne fréquence selon la condition voulue avec la fonction =SOMME.SI

=SOMME.SI(B:B;F2;D:D)

Ainsi on sommera 4 fois le poids de 1/4 pour une valeur apparaissant 4 fois: cela revient à ne compter la valeur qu’une seule fois.

Exemple fichier 2.xlsx (19,3 Ko)

1 J'aime

Super !
Encore merci pour cette réponse efficace et rapide !