Formule excel restreint en nombre de ligne

Bonjour,

J’ai fichier Excel avec 2 feuilles.

La première feuille « DR » . En rentrant juste le numéro du véhicule va allez chercher toutes les informations dans la deuxième feuille.

Mais j’ai un souci avec ma formule en A9 de la feuille DR, =SIERREUR(INDEX(colh;PETITE.VALEUR(SI(colg=$C$5;LIGNE(colg)-3;"");LIGNE(A1)));"")

la formule s’arrête à la ligne 340 de la colonne G de la deuxième feuille et je ne sais pas pourquoi ?

J’ai enregistré le fichier exprès sur le dernier véhicule qui fonctionne et encore il me manque 3 lignes des gammes opératoires.

Quelqu’un aurait-il une solution ?

En vous remerciant par avance de votre temps.

essai XX DR cie.xlsm (45,6 Ko)

Bonjour,
à tester
essai XX DR cie.xlsm (45,9 Ko)

Bonjour Mimimathy,
Cela à l’air de fonctionner correctement :slight_smile: puis-je te demander quel modif tu y a fais?

Re,
regarde dans le gestionnaire de noms « colg »
dans ton fichier d’origine, il s’arrête à la ligne 340,
j’ai modifié pour que ce noms soit dynamique. càd que si tu rajoutes des données en fin de colonne G, elles seront prisent en compte