Données référentielles tiers - besoin de formule MAITRE/DOUBLON

Bonjour
Aide fiabilisation tiers.xlsx (15,6 Ko)

J’ai un fichier qui possède des données qualifiés par un fournisseur X et qui sont comparées avec le référentiel tiers d’une application Y. Force est de constater que nous avons des doublons de codes tiers de part leur siret.
Il me faut pouvoir mettre en avant parmi les doublons de siret, ceux qui seront Maitre et ceux qui seront considérés comme doublon.
Pour ce faire je pense ( mon niveau de formules excel ne le permet pas ) qu’il faut probablement l’usage de 2 formules dans une meme cellule. Je crois que cela se fait.
Enfin qu’importe la solution, tant que le résultat et là.
Je sollicite votre aide en espérant que vous aurez un peu de temps à m’accorder.

Voila ce que je cherche à mettre en language Excel

1 Si un même siret existe plus d’une fois dans la colonne C (SIRET2) alors le maitre est celui qui possède ce même SIRET dans la colonne B (SIRET1)

2 Si aucun ne possède le même siret dans la colonne B (SIRET1) alors c’est celui qui possède le code source le plus petit (colonne A) qui devient maitre.

3 Les maitres doivent avoir la valeur « Maitre » dans la colonne D(MAITRE/DOUBLON) les autres doivent avoir la valeur « Doublon ».

|Exemple 1|||||

|code_source| SIRET1 | SIRET2 | MAITRE/DOUBLON|
|0000190541| 38090434200017 | 38090434200025 | |
|0000192667| 38090434200025 | 38090434200025 | |
|0000190190| 38090434200016 | 38090434200025 | |

==> ici c’est le point 1 qui doit être appliqué soit le maitre est le 0000192667 car le siret 2 = siret 1. les deux autres codes sources doivent être indiqués comme Doublon

|Exemple2|
|code_source|SIRET1 |SIRET2 |MAITRE/DOUBLON|
|0000300300|38090434200017|38090434200025| |
|0000400400|38090434200024|38090434200025| |
|0000200200|38090434200016|38090434200025| |

==> ici c’est le point 2 qui doit être appliqué soit le maitre est le 0000200200 et les deux autres codes sources doivent être indiqués comme Doublon

Je vous remercie d’avance pour votre aide !!! :slight_smile:

Bonjour Kainna

Voici la formule à tester, attention il faut penser à modifier les plages

=SI(NB.SI($B$3:$B$5;C3)>0;SI(B3<>C3;"Doublon";"Maitre");SI(SOMMEPROD(MIN(CNUM(A$3:A$5))*1)<>CNUM(A3);"Doublon";"Maitre"))

Voici le fichier
Kainna_Aide fiabilisation tiers.xlsx (23,6 Ko)

A+

Bonjour
Super merci pour cette formule!!!
Je vais l’appliquer à tout mon fichier en espérant que je mette bien les plages à jour car ce ne sont pas les même colonnes
Je reviens vers vous pour vous remercier encore mille fois :slight_smile:

Bonjour
J’ai adapté la formule dans le fichier final, néanmoins je rencontre un cas de gestion qui amène à faire évoluer la formule. Si vous pouviez m’aider à nouveau ca serait très gentil à vous.

Voici ce qui manque

Si le siret 2 = Siret 1 alors celui ci est maitre ça c’est OK
SI le siret 2 est présent sur plusieurs lignes dans la colonne Siret 1 alors le maitre est celui qui a le plus petit code source.

En l’état je me retrouve avec deux lignes maitre sur 3 car deux tiers ont le meme siret entre la colonne Siret 1 et Siret 2.

J’ai joins un exemple dans le fichier excel.

Merci d’avance !
Kainna_Aide fiabilisation tiers;V2.xlsx (17,7 Ko)

Bonjour Karinna,

Il faut alors ajouter une condition en cas de valeur vrai à la 1ère condition

Rappel de l’utilisation de SI(Condition;Valeur_SiVrai;Valeur_SiFaux)
Ce qui donne :

=SI(NB.SI($B$3:$B$5;C5)>0;SI(B5<>C5;"Doublon";SI(SOMMEPROD(MIN(CNUM(A$3:A$5))*1)<>CNUM(A5);"Doublon";"Maitre"));SI(SOMMEPROD(MIN(CNUM(A$3:A$5))*1)<>CNUM(A5);"Doublon";"Maitre"))

Voici le fichier
Kainna_Aide fiabilisation tiers v2.xlsx (23,8 Ko)

A+

Merci mais si je change la ligne 5 par un siret 1 se terminant pas 18 par exemple, je n’ai que des doublons. Alors que la règle de l’exemple 2 doit s’appliquer. Le code source le plus petit doit être considéré maitre mais ce n’est pas le cas.
Faut il que je mette à la suite de la formule de l’exemple 1 la formule de l’exemple 2?

Merci

Re,

Effectivement :thinking: perso n’étant pas patient et ayant déjà passé pas mal de temps sur le sujet (trop à mon goût) je laisse tomber, désolé.

Bonne chance

Bonjour
Aie dommage vous me paraissiez tellement expert !

En tout cas merci encore pour le temps accordé !

Bon reste plus qu’a trouvé quelqu’un qui puisse me débloquer.

Merci encore !