Décaler tout un bloc + étirage

Bonjour,

J’ai un petit soucis, mon objectif est de décaler tout le bas du
tableau avec une macro.

Il faut que lorsque l’on appuis sur la le bouton la partie A5:D12
soit décalé d’une ligne vers le bas, et que la ligne sur C4 soit
soit dupliqué, en faisant la suite la suite,
C3=SOMME(J5:J16) - C4=SOMME(K5:K16)…

J’arrive à le faire par contre la colonne C n’est pas dupliquée mais
uniquement copié.

Si au passage vous savez comment faire pour que la cellule A8 soit
toujours fusionné après !

J’espère que c’est compréhensible

Test décalage ligne.xlsm (80,5 Ko)

Bonjour

Ci-joint ma proposition
Cliques sur le bouton « Ajouter une ligne »
Testes et dis moi

Test décalage ligne.xlsm (83,7 Ko)

Ce n’est pas ça, c’est la partie A5:D12 qui doit bouger comme je l’ai marqué

Elle bouge puisque décaler à chaque traitement d une ligne
Sinon tu n es pas claire dans ta demande
Merci de donner plus de précisions sur ce qu il faut réaliser avec un exemple de l attendu dans ton fichier

Effectivement en relisant tes consignes tu souhaites décaler les lignes des colonne A à D et non I à K comme je te l’ai proposé

Mais je ne comprends plus ceci :

« et que la ligne sur C4 soit
soit dupliqué, en faisant la suite la suite,
C3=SOMME(J5:J16) - C4=SOMME(K5:K16)… »

Qu’attends tu de ces formules puisque les données des colonnes I à K ne sont pas concernées par l’ajout de la ligne

C’est ce qui m’a trompé

Merci pour ta clarification sur ce point