Trouver la liste de code

BOnjour, j’ai dans un tableau toute une liste de code qui se repete, comment trouver par une formule la liste de ces codes sans doublons; qu’on peut voir en faisant le filtre code.xlsx (24,9 Ko)

Merci de votre aide…

Bonjour,

Avec une colonne supplémentaire qui donne un N° à chaque valeur différente
A mettre en D2 et tirer jusqu’en bas (La colonne peut-être masquée)

=SI(C2="";"";SI(NB.SI($C$1:C1;C2)>0;"";MAX($D$1:D1)+1))

Pour la liste, mettre cette formule en G4 et tirer vers le bas

=SIERREUR(INDEX(C:C;EQUIV(LIGNE()-3;D:D;0));"")

Adrien.xlsx (45,8 Ko)

SUPER RAPIDE et super efficace…merci beaucoup…c’est justement la formule idéale

Bonjour @Adrien,
Salut @Mimimathy, :wink:

Une modeste contribution:

En “G4”

=SIERREUR(INDEX($C$2:$C$1046;EQUIV(0;INDEX(NB.SI(G$3:G3;$C$2:$C$1046);0;0);0)); "")

Tirer vers le bas autant que nécessaire.

Cordialement.

1 J'aime

Salut MDO

Modeste :joy:, avec une formule tu me remplaces mes deux… (formules) :grin: :+1::+1:

1 J'aime

Re @Adrien,

Pour prendre en compte les futures données dans la colonne “C” comme @Mimimathy l’a proposé, on peut nommer la colonne dans le “Gestionnaire des noms” avec cette formule.

=DECALER('Rapport 1'!$C$2;;;NBVAL('Rapport 1'!$C:$C)-1)

Puis écrire en “G4”

=SIERREUR(INDEX(Code;EQUIV(0;INDEX(NB.SI(G$3:G3;Code);0;0);0)); "")

Tirer vers le bas autant que nécessaire.

Fichier ICI==> Adrien V1.xlsx (27,6 Ko)

Cordialement.

Édit: @Mimimathy merci de ton compliment, bon retour de vacance.

Amicalement.

Merci beaucoup pour ces différentes formules…qui facilitent le travail…

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.