Trouver et Calculer des cellules


#1

Bonjour, pouvez vous m’aider svp ?
Voila j’aimerai calculer des cellules en fonction d’un résultat

ex : si dans la cellule H2 = Bordeaux Et dans la cellule H3 c’est psg

alors trouver le resultat de bordeaux et de paris dans la colonne P

Sachant que le resultat des cellules H2 et H3 varie

Voir onglet classement
codialement

Essai 1.xlsx (62,7 Ko)


#2

Bonjour

Pour rechecher une valeur dans un tableau la formule la plus simple est RechercheV

Dans ton cas on va utiliser la formule suivante pour tes pronostics de football:

=(RECHERCHEV(L2;$O$2:$P$21;2;0)+RECHERCHEV(L3;$O$2:$P$21;2;0))/2

qui recherche la valeur de L2 dans la première colonne du tableau $O$2:$P$21 et renvoie le contenu de la deuxième colonne

De meme pour L3

Attention tes noms de clubs de foot ne sont pas cohérents des fois il y a un espace supplémentaire après le nom et des fois non (ce qui va faire planter tes formules)

Essai 1.xlsx (62,5 Ko)


#3

merci beaucoup pour votre aide. je vais voir ensuite pour les espaces
bonne fin de journée


#4

Si ton problème est résolu n’oublie pas de le marquer comme tel stp en cochant le petit :white_check_mark: sous la solution!


#5

J’essaye la formule pour l’instant ça ne fonctionne pas. ça doit être les espaces y a t’il une solution pour supprimer les espaces ?


#6

je viens de faire =SUBSTITUE(H3;H3;“ParisSG”;1)
pour supprimer l’espace et cela ne fonctionne pas
Avez vous une autre solution


#7

Oui il faut que tu vérifies partout dans tes noms de club s’il y a un espace à la fin, je te suggère de le retirer.

Tu peux aussi le faire avec une formule qui enlève le dernier caractère si c’est un espace:

=SI(DROITE(A1;1)=" ";GAUCHE(A1;NBCAR(A1)-1);A1)


#8

Super merci beaucoup
bonne fin de wk