Transformer un nombre décimal en un nombre entier


#1

Bonjour,

J’aimerais, utiliser la fonction tronque pour en quelques sortes
transformer un nombre décimal en un nombre entier. Cependant, j’aimerais
que ce nombre entier soit arrondi en fonction de son dixième le plus
proche. Or, la fonction tronque semble arrondir à l’entier inférieur.
Le contexte est le suivant: je cherche à additionner deux nombres décimaux
apparaissant comme des entiers (j’ai réduit pour cela le nombre de
décimales à 0). J’ai donc en apparence un nombre entier arrondi à la
décimale la plus proche. Mais lorsque je fais la somme de ces mêmes nombres
apparaissant comme des entiers, le nombre que j’obtiens prend en compte les
décimales de ces nombres que j’additionne.

Exemple: je souhaite additionner 2 nombres décimaux dont je fixe le
nombre de décimales à 0; disons 6244,3 et 2066,4. On est bien d’accord que
lorsque je fixe le nombre de décimales à 0, on ne voit plus ce qu’il y a
après la virgule et on a donc en apparence deux nombres entiers.
Cependant, lorsque je fais la somme des deux cellules contenant ces deux
nombres, la somme résultante vaut 8311 si je fixe le nombre de décimales à
0 et 8310,7 si je fixe le nombre décimal à 1. Là est le problème. Je veux
en fin de compte additionner deux nombres entiers, sans chiffre après la
virgule. On est d’accord que si ça avait été le cas, on aurait obtenu 8310
et non 8311.

Je ne sais pas si j’ai été très claire.
Merci d’avance.

Cordialement,

Amelle Aït-adi


#2

#3

Bonjour!

Je ne suis pas sur d’avoir bien compris ta question.
Pourrais tu nous donner plus de détails stp et si possible inclure un fichier d’exemple?
Idéalement en incluant ce que tu obtiens, et ce que tu voudrais à la place.

Merci et à bientôt


#4

En rouge surligné hors du tableau: ce que je souhaite obtenir si l’on fixe
le nombre de décimales à 0 pour tous ces nombres (et donc on considère que
ce sont des nombres entiers)

en arrondissant, tout en fixant le nombre de décimales à 0, on obtient ça:

:


#5

Je crois avoir une idée. Je pense qu’en utilisant la fonction tronque et
arrondi, ça devrait régler le problème. Mais je ne sais pas comment
utiliser ces deux fonctions dans une même cellule… J’ai essayé avec "&"
mais ça ne fonctionne pas…


#6

En fait tu veux arrondir à l’entier inférieur?
Il y a la fonction ARRONDI.INF pour cela.
D’ailleurs tu peux spécifier à quel nombre de chiffres après la virgule arrondir.


#7

Bonjour à tous

teste comme ceci
=ARRONDI.INF(SOMME(A2:A3);0)

avec A2 et A3 correspondant à tes données avec décimale


#8

Non, j’ai déjà fais un test avec la fonction ARRONDI.INF mais c’est bancal
parce que j’ai ce problème là avec plusieurs tableaux et des fois je dois
faire des ARRONDI.SUP sauf que si les nombres dont on fait la somme
changent au cours du temps, on va devoir réajuster les arrondis, donc c’est
vraiment pas l’idéal…

:


#9

Du coup il faudrait que tu listes précisément tous les différents cas possibles de nombres, et quel arrondi tu veux

Dans ton exemple la formule ARRONDI.INF(H5-0,1;0) fonctionne


#10

Bonjour Amelie_Atd, toutes et tous,

Un essai avec la fonction “TRONQUE”

=TRONQUE($G$65+SOMME($F$66:F66);0)

Puis tirer vers le bas autant que nécessaire.

Cordialement.


#11

Je vous joins ci-contre le fichier en question pour que vous puissiez mieux
comprendre mon problème:

(en surligné rouge, c’est ce que j’obtiens et ce que je souhaite obtenir
est en surligné vert à côté des tableaux)
Lorsque ce n’est surligné ni en vert ni en rouge, c’est que les valeurs
sont justes.

Classeur1.xlsx (56 KB)


#12

Re Amelle_Atd,

Je pense que nous avons tous été induit en erreur, par manque de fichier explicite.

Donc:

En “G17”

=ARRONDI(M17*'Données '!$D$8;0)

En “F18”

=ARRONDI(L18*'Données '!$D$8;0)

Ses formules sont a copier dans les autres tableaux, je l’ais fait et on obtient sauf erreur les bon résultats dans la colonne “G”.

Ton fichier en retour ICI==> Amelle_Atd V1.xlsx (53,3 Ko)

Cordialement.


#13

Merci beaucoup! Ca fonctionne très bien, même si je ne comprends pas bien
le raisonnement haha. La fonction ARRONDI permet de transformer un nombre
décimal en nombre entier? Parce que je pensais que c’était le cas de la
fonction TRONQUE uniquement. (Et j’avais pour idée d’utiliser ces deux
formules en une seule cellule pour régler ce problème -qui maintenant est
réglé grâce à votre aide-)