Transformer Formule en Macro


#1

Bonjour,
j’ai besoin de transformer cette formule en macro.
Elle a pour fonction de supprimer un underscore dans un mot si le underscore est en 6ème position dans un mot.
La formule fonctionne parfaitement mais environ 30000 lignes à traiter.

=SI(TROUVE("";A1)=6;SUBSTITUE(A1;"";"");A1)

A1 sera à remplacer par colonne A.

Merci pour vos contributions.


#2

Bonjour @chopin26,

Bizarre cette formule, tu dis que tu veux supprimer l’underscore d’un mot dans une ou plusieurs cellules, et que la formule fonctionne parfaitement :thinking:

Pour moi, l’underscore s’obtient avec la touche F8 " _" et je ne vois pas ça dans ta formule.

Peux-tu nous joindre un p’tit fichier illustratif avec la formule.

Pour joindre un fichier, suivre cette procédure:
Joindre un fichier

@+
Cordialement.