TCD valeur Σ = texte


#1

Bonjour,
Ci-joint mon fichier pour lequel je peine à solutionner mon problème.
L’onglet PRÉVISIONNEL est ma source.
L’onglet AFFAIRES est juste une feuille où je liste les informations sur les affaires.
L’onglet MISSIONS est juste une feuille où je les mes missions.
L’onglet TDC est mon tableau croisé dynamique.
Dans cet onglet, j’ai déjà bâti deux tableaux.
Le premier est un TCD.
Le second est un simple tableau qui montre ce que j’attends du TCD.
En résumé, dans mon TCD, le code est ma mission.
Je suis ouverte à toute solution même une macro s’il le faut.
Merci par avance de votre aide.Classeur1.xlsm (57,0 Ko)


#2

Bonjour

En fait l’utilisation du TCD n’est pas super adaptée car chaque cellule ne contient qu’une seule valeur.

Je te conseille donc de le remplacer par des fonctions de somme (par exemple SOMME.SI.ENS) en fonction du projet et du mois, pour afficher les montants hors taxe.
Puis une fonction de recherche (RechercheV) en fonction du projet et du mois pour afficher le code correspondant.


#3

Bonjour @Cannamella,
Salut @DocteurExcel,

@Cannamella, une proposition par formule dans la feuille “Résultats”:

En “B1&C1” fusion de ses 2 cellules
Puis en “D1&E1”:

=MOIS.DECALER(B1;1) et tirer vers la droite autant que nécessaire.

En “B3” Formule matricielle a valider avec ctrl + maj + entrée

=SIERREUR(INDEX(PRÉVISIONNEL[€ HTVA];EQUIV($A3&B$1;PRÉVISIONNEL[Opération]&PRÉVISIONNEL[Éxécution];0));"")

En “C3” Formule matricielle a valider avec ctrl + maj + entrée

=SIERREUR(INDEX(PRÉVISIONNEL[Missions];EQUIV($A3&B3;PRÉVISIONNEL[Opération]&PRÉVISIONNEL[€ HTVA];0));"")

Une fois ses 2 formules écrites, sélectionner “B3 & C3” puis tirer vers la droite et vers le bas autant que nécessaire.

Somme en bout de ligne une colonne sur 2.

En “N3” Formule matricielle a valider avec ctrl + maj + entrée

=SOMME(SI((MOD(COLONNE(B3:M3);2)=0);(B3:M3)))

Ci-joint ton fichier ICI==> Cannamella V1.xlsm (60,2 Ko)

Cordialement.


#4

En un mot, c’est GÉNIAL.
Ça vous me changez la vie au bureau.
Merci beaucoup pour votre aide et votre efficacité.


#5

Bonjour @Cannamella,

Si ton problème est résolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Merci.
Cordialement.