Tableau pour suivre les résultats du loto sur Excel

Bonjour

j’aimerais savoir si c’est possible avec Excel de faire un tableau de 1 à
50 ou le résultat et un cercle et non pas un chiffre ( pour suivre
visuellement les résultat du loto)

les 5 premières cellules de la ligne A sont le résultat du tirage par
exemple 1 15 17 35 47 et j’aimerais que ces no apparaissent à leur place
dans la ligne et sous forme de boule.
La 1er place des boule est décalée de 5 cellules à cause du résultat du
tirage soit le 1 à la position 6 le 15 à la position 20 le 17 à la
position 22 etc.

je suis impatient de votre réponse et je vous présente mes salutations

Bonjour!

Je ne suis pas sur d’avoir bien compris ta question.
Pourrais tu nous donner plus de détails stp et si possible inclure un fichier d’exemple?

Merci et à bientôt

Bonjour

J’ ai fait un exemple du tableau avec les 2 derniers tirages

Merci salutations

:

Exemple Loto.xlsx (8.89 KB)

Bonjour

En H4:

    =SI(ESTERREUR(RECHERCHEH(H1;$B4:$F4;1;0));"";"o") 

Cela consiste à rechercher la valeur dans la liste des 5 valeurs tombées, puis renvoyer la chaine vide si la valeur n’est pas trouvée, la lettre o sinon

1 J'aime

Bonjour Yvan_Lesquereux, @DocteurExcel,

Voici une proposition si j’ai bien compris:

En “H2”

=SI(H$1=$B2;"☻";SI(H$1=$C2;"☻";SI(H$1=$D2;"☻";SI(H$1=$E2;"☻";SI(H$1=$F2;"☻";"")))))

Tirer vers la droite et vers le bas autant que nécessaire.

Pour obtenir :slight_smile: faire " alt + 2 " et coloriser en vert par exemple ne pas oublier les guillemets avant et après.

Ton fichier ICI==> Yvan_Lesquereux Loto.xlsx (12,6 Ko)

Cordialement.

Re @DocteurExcel,

Je n’avais pas vu ta réponse et effectivement elle est plus courte que la mienne :wink: .

J’ajouterais juste le blocage de la ligne 1 H$1

Amicalement.

Bonjour à tous

Comme le demandait YVAN, l’affichage des boules sur les cases correspondantes

A testerloto.xlsm (601,1 Ko)

En colonne BF le bouton tirage mets en place les boules et place une croix sur la colonne BE si le tirage est effectué. (Pour éviter de réintégrer les boules)
Le bouton EFFACER TOUT efface tous les tirages.

Option Explicit

Sub Tirage()
Dim i%, j%, l%, lig% 'Variables
lig = Range("A" & Rows.Count).End(xlUp).Row  'Dernière ligne
  For l = 2 To lig  'Boucle sur lignes
    If Cells(l, 57).Value = "X" Then l = l + 1  ' Vérifie que la colonne BE a un "X3, si oui , augmente d'une ligne
    For j = 2 To 6  'boucle sur les colonnes B à F
      For i = 8 To 56 ' boucle sur les N° de boules
        If Cells(1, i).Value = Cells(l, j).Value Then  'rechercher le N° dans la ligne
          Sheets("Boules").Shapes("Image " & i - 7).Copy  'Si N° trouvé il copie l'image de la boule
          Sheets("Relevé").Select
          Cells(l, i).Select
          ActiveSheet.Paste  'et la colle
        End If
      Next i
    Next j
    If Cells(l, 2).Value <> "" Then Cells(l, 57).Value = "X"  'Place un "X" en colonne BE
  Next l
Range("A1").Select
End Sub

Sub EffaceImages()  'Efface tous les Images de la feuille RELEVE
Dim x As Shape
  For Each x In ActiveSheet.Shapes
    If x.Type = msoPicture Then x.Delete
  Next x
Columns("BE").ClearContents  'Efface tous les "X"
End Sub
1 J'aime

Salut @Mimimathy, :pray:

Génial :+1: ta proposition, je voulais le faire avec des formules et puis je me suis emmêlé les pinceaux, alors je n’ais pas eu le courage d’aller plus loin.

En tout cas :clap: pour cette belle démonstration par VBA.

Pendant que tu y es et si cela ne te dérange pas, peux-tu ajouter une colonne ou serait placé le numéro complémentaire avec les boules de “1 à 10” identifié avec une autre couleur ou un signe distinctif.

Amicalement.

Salut MDO

Dis, tu pousserais pas le bouchon un peu trop loin Maurice :grin:

Je suis entrain d’étudier le problème, avec un peu de mise en forme en plus

1 J'aime

Bonjour à tous

Bon, à la demande de MDO, une petite amélioration avec le N° Chance en surplus, et une p’tite présentation

loto.xlsm (835,6 Ko)

1 J'aime

Salut l’ami @Mimimathy,

Beau travail de présentation, c’est beaucoup plus agréable comme ça :clap:

Combien te dois-je ? Quel est ton pourcentage si je gagne ?
billets

En tout cas merci :pray: d’avoir accédé à ma demande pour le N° Chance et aussi pour l’amélioration du code VBA.

Dommage que nous n’ayons plus de nouvelle du demandeur à l’origine de la question.

J’ai une dernière requête: Peux-tu me donner les N° Gagnants pour le tirage de ce soir ? :roll_eyes::joy::rofl:

Allez, à la prochaine sur le forum et encore merci pour ton travail au service de la communauté.

Bien amicalement.

Salut MDO,

Si tu viens à gagner le “Jackpot”, j’en serais heureux pour toi et tes proches. De mon côté, je ne demande rien.
L’argent ne me redonnera pas la santé.

Et comme je ne joue pas aux jeux de hasard, je ne te donnerai aucun numéro.
Moi je gagne à chaque tirage, la mise du jeu

Bonne journée et surement @+

1 J'aime

Hello

j’ai reçu plusieurs réponses à ma question
comme j’ai congé aujourd’hui je vais pouvoir
faire des essais.

Je ne sais pas à qui dire merci alors merci à tout le monde pour l’aide c’
est trop super!!
Yvan

Hello

j’ai reçu plusieurs réponses à ma question
comme j’ai congé aujourd’hui je vais pouvoir
faire des essais.

Je ne sais pas à qui dire merci alors merci à tout le monde pour l’aide
trop cool
Yvan

Bonjour

Si ton problème est résolu, peux-tu stp cocher le petit :white_check_mark: sous le message qui contient la solution stp?

Cela nous aide à déterminer qui a encore besoin d’aide et qui est sauvé!

Merci

1 J'aime

Hello
je n’ai rien trouvé à cocher sous le message
mais je confirme que j’ai trouvé la solution
Merci encore et salutations Yvan