Sommeprod multicritère


#1

bonjour

merci d’avance

=SOMMEPROD(J50:J650;G50)*SOMMEPROD(N50:N650;“g”)*SOMMEPROD(U50:U650;G50)

j’ai utilisé nombre de formules mais je bloque sur la compréhension de la formule et sur l’énoncé de ma recherche

je recherche la somme des points obtenus par un filleul identifié en cellule G50 dans la liste des parrain J50 a J650 avec un distingo entre les "G cumul a déposer dans la colonne L50 et un distingo entre les "D cumul a déposer dans la colonne M50. les sommes sélectionnées de la colonne U

			 cp 		filleuls	68		parrain		Gauche	...................Droit	 7   	484	161		xxx	 P 	mai-17	

col a… colonne G… colonne J… colonne L…colonne L
aa …xxr 1xx 00 015732 …xxx x 011973. …xx RESULTAT Gauche resultatdroit!

colonne N…colonne U
DD1 00 € 000 00E 55


#2

Bonjour @jff74650,

Si tu as écris la formule comme ça, elle est fausse.

Mais pour pourvoir t’aider et t’expliquer, j’aurais besoin d’un petit bout de fichier, peux-tu nous en fournir un.

Pour joindre un fichier:

@+


#3

bonjour
merci de votre retour rapide
merci egalement de m’avoir indiqué comment joindre un fichier j’avoue
ne pas l’avoir vu
encore merci d’avance.

Classeur1.xls (205 KB)


#4

Re @jff74650 alias Jean-François_Fourni :two_men_holding_hands: enfin bonsoir à vous deux :joy:

Bon si j’ai bien compris ce que tu veux dans ce dédale de couleurs et de pages.

En “L50”:

=SOMMEPROD(($J$50:$J$650=$J50)*NB.SI($N$50:$N$650;"*g*")*($U$50:$U$650))

En “M50”:

=SOMMEPROD(($J$50:$J$650=$J50)*NB.SI($N$50:$N$650;"*d*")*($U$50:$U$650))

Formules a tirer vers le bas autant que nécessaire.

Cela convient-il ?

Cordialement.


#5

Re @jff74650,

Quoi que j’ai un doute.

Je propose autre chose pour résoudre le problème posé.

J’ai vu qu’en colonne “H” il n’y avait rien, alors je propose un concaténation des cellules “G50 & J50” dans “H50” ce qui forme une numéro unique entre filleul et parrain.

En “H50”:

=G50&J50 et tirer vers le bas.

En “L50”:

=SOMMEPROD(($H$50:$H$650=$H50)*($G$50:$G$650=$G50)*NB.SI($N$50:$N$650;"*g*")*($U$50:$U$650))

En “M50”:

=SOMMEPROD(($H$50:$H$650=$H50)*($G$50:$G$650=$G50)*NB.SI($N$50:$N$650;"*d*")*($U$50:$U$650))

Fait moi savoir si cela convient.

Cordialement.

PS: on peut aussi en y réfléchissant bien éviter de mettre des formules dans la colonne “H”.

Du coup cela donnerait:

En “L50”:

=SOMMEPROD(($G$50:$G$650&$J$50:$J$650=$G50&$J50)*($G$50:$G$650=$G50)*NB.SI($N$50:$N$650;"*g*")*($U$50:$U$650))

En “M50”:

=SOMMEPROD(($G$50:$G$650&$J$50:$J$650=$G50&$J50)*($G$50:$G$650=$G50)*NB.SI($N$50:$N$650;"*d*")*($U$50:$U$650))

Bonne soirée.


#6

bonjour
grand merci
je pars à disney pour notre convention (500 personnes pour le we)
et je testerai à mon retour
mais celà me semble super ainsi que la compression g50 et j50
pourquoi dis tu “bonsoir à vous deux” ce qui est exact, tu nous connais.
je suis en hte savoie
a bientot
amitiés à toi.
jean francois