SOMMEPROD conditionnel selon texte et substitue du texte

Bonjour,

Je n’arrive pas à mettre en place une formule, qui permette “simplement” de faire une somme en fonction d’une valeur, avec un substitue.

Je m’explique. Imaginons le tableau suivant:


5RO| |10RO| 3RO |

Je veux additionner les nombres, en enlevant le RO, ce que je parviens à faire avec cette formule:
=SOMMEPROD(VALEURNOMBRE(SUBSTITUE(A1:D1;"RO";"")))

Mais, maintenant, je voudrais pouvoir ne compter que les cellules qui contiennent bien “RO”, car je peux avoir aussi d’autres valeurs dans cette même ligne, par exemple :


5RO|3P|10RO| 3RO |2R|

Du coup, j’ai essayé la formule suivante :
=SOMMEPROD((ESTNUM(CHERCHE("RO";A1:E1)))*(SUBSTITUE(A1:E1;"RO";"")))

Mais j’ai une erreur…

Merci d’avance,

Bonjour @guilt92,

Faire un essai avec cette formule:

=SOMME(SI(ESTNUM(TROUVE("RO";A1:E1));CNUM(GAUCHE(A1:E1;TROUVE("RO";A1:E1)-1));0))

Formule matricielle a valider avec ctrl + maj + entrée

Cordialement.

1 J'aime