Si a1>=1;a1<=4 alors =a1

Bonjour, afin de créer un tableau automatiser pour le calcul des heures supplémentaires j’aurai besoin d’aide pour la formule qui permet de déterminer les heures.

Par exemple : je travail 40 (cellule A1)

Heures normales : 35 (cellule A2)
Nombre d’heures supp : 5 (cellule A3)
HS à 10% : 4 (cellule A4)
HS à 20% : 1 (cellule A5)

Je voudrais que ça me donne :

HS 10% : Si A3 < 1 alors A4=0; Sinon si A3 est >=1 et A3<=4 alors A4 = A3; Sinon si A3>4 alors A4=4

HS 20% : Si A3 est >4 et A3<=8 alors A5 = A4 - A3; Sinon si A3 > 8 alors A5 = 4

J’espère avoir été clair dans mon explication :slight_smile:

Je vous remercie d’avance pour votre aide !

Bonjour,
en imbriquant Les 2 : =SI(A3<1;A4=0;SI(ET(A3>=1;A3<=4);A4=A3;SI(A3>4;A4=4;si(et(A3>4;A3<=8);A5=A4;SI(A3>8;A5=4;"")))))

Sinon, pour 10% : =SI(A3<1;A4=0;SI(ET(A3>=1;A3<=4);A4=A3;SI(A3>4;A4=4;"")))

pour 20% : =SI(et(A3>4;A3<=8);A5=A4;SI(A3>8;A5=4;""))``

1 J'aime

Bonjour
En A3

=A1-A2

En A4

=SI(A3<1;0;SI(ET(A3>=1;A3>4);4;A3))

En A5

=SI(A3<1;0;SI(A3>4;A3-4;""))
1 J'aime

Merci ça marche nickel je vous remercie :slight_smile: