Retranscrire une phrase en formule


#1

Bonjour,
Je souhaiterais retranscrire un phrase en formule mais je n’y arrive pas.

Je souhaite calculer la somme des cellules de couleur compris entre telle date et telle date.
J’ai les deux formules ci-dessous mais je n’arrive pas à les lier :
=SOMME_SI_COULEUR($G$4:$G$37;$B$40)
=SOMME.SI.ENS($G$4:$G$37;$F$4:$F$37;">01/01/2018";$F$4:$F$37;"<01/02/2018")

Pouvez-vous m’aider ?

Cordialement,


#2

Bonjour,
Certainement, mais avec un p’tit classeur modèle, c’est mieux :wink:


#3

Bonjour,

SUIVI FACTURES - 2018.xlsm (59,3 Ko)


#4

Bonjour,

Avec une colonne intermédiaire (que l’on peut masquer)

Il suffit pour l’année 2017 de la modifier en A41

=SOMME.SI.ENS($G$4:$G$37;$F$4:$F$37;">="&DATE($A$41;LIGNE()-41;1);$F$4:$F$37;"<"&DATE($A$41;LIGNE()-40;1);$H$4:$H$37;"R")

la date de début et fin est en rapport avec la fonction LIGNE()
Ligne(), donne le N° de la ligne
pour Janvier qui est en ligne 42, c’est =LIGNE()-41, qui donne 1 pour le mois de Janvier
accouplé à la fonction DATE(année de cellule A41; mois(ligne()-41;1 pour le 1er du mois)

SUIVI FACTURES - 2018.xlsm (60,8 Ko)


#5

Bonjour,

Merci beaucoup !!!

Cordialement