[Résolu] Recherche dans plusieurs intervalles

Bonjour,

Je souhaite effectuer une recherche dans une base de données Excel.
Je m’explique, j’ai une base de donnée regroupant les valeurs suivantes :
Nom diam_min diam_max ep_min ep_max
Dim1 10,7 30,20 1,94 5,00
Dim2 10,7 30,20 5 9,56
Dim3 30,2 60,30 1,5 3,00

Je souhaite retrouver le nom associé (Dim1, Dim2 …) à un diamètre et une épaisseur donnée.
Par exemple: Je cherche : diamètre = 20.9 épaisseur = 8.5
la formule me renvoie --> “Dim2”

Comment faire ?

Classeur1.xlsx (8,9 Ko)

Merci d’avance, je vous joins le fichier excel.

Bonjour,
un petit essai avec des mises en forme conditionnelle.
Bonne journée.

Diam.xlsx (15,2 Ko)

Bonjour,
Il me semble que la fonction recherchev fait cela.
Par contre, je n’ai que mon smartphone avec moi. Dès que j’ai un PC, je vérifierai

Merci pour vos réponses. J’ai également trouvé un autre solutions sur un autre forum.

En supposant que les valeurs cibles sont en H1 et I1.
En supposant que la cellule “Nom” soit A1, mettre en F2 la formule :

`

=SI(ET($H$1>=B2;$H$1<=C2;$I$1>=D2;$I$1<=E2);“X”;"-")

`

Copier F2 vers le bas sur toute la longueur du tableau.

Utiliser ensuite la formule :

=INDEX(A2:A4;EQUIV(“X”;F2:F4;0))

S’il y a plusieurs occurrences correspondant au critère, la formule ne renverra que la première.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.