Rechercher suivant une validation de donnée indirect


#1

Messieurs,
Je souhaite votre aide, pour m’expliquer ou est le problème dans ma formule.
J’ai créé une validation indirect et de là, je souhaite récupérer son poids.
Ci joint l’exemple
calcul.xlsx (61,5 Ko)

Vous en remerciant par avance.


#2

Après toute la matinée à chercher, j’ai simplement réussi en écrivant la formule du départ.
Cela m’a permis de virer la liaison qui me semble déstabilisé la formule.
Pou info


#3

Bonjour @pat44,

Si tu as trouvé l’erreur c’est parfait :wink:

Pour ma part voici comment écrire ta formule dans la cellule "G13’:

=SI(ESTVIDE($D13);"";RECHERCHEV($D13;DECALER(données!$B$1;EQUIV($C13;données!A:A;0)-4;;NB.SI(données!A:A;$C13);2);2;0))

Cordialement.


#4

Merci à toi pour cette solution