Recherche de valeurs avec plusieurs tableaux

Bonjour,
je suis en train de réaliser un tableau excel pour la gestion d’un cross. Je suis bloqué pour récupérer la place des élèves.
Je souhaiterai que dans mon onglet par exemple classe de 6B, qu’excel soit capable de me donner la place et le temps réalisé pour l’élève en récupérant les données des courses BF et BG.
J’avais l’impression d’avoir réussi, mais la formule ne fonctionne pas pour les garçons (BG)

Une âme charitable pourrait elle m’éclairer SVP ?

par avance merci
logiciel cross 2017-2018 v3.xlsx (166,7 Ko)

Bonjour nathalietimon,

Je te fais une proposition, j’ai mis les résultats dans les colonnes “G & H” je te laisse les replacer dans les colonnes “E & F”
Je sais que l’on peut faire plus simple en nommant les feuilles, mais c’est tout ce que j’ai pour le moment.

Donc:

En “G3”

=SIERREUR(INDEX(BF!$A$4:$A$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);BF!$B$4:$B$103&BF!$C$4:$C$103&BF!$D$4:$D$103&BF!$E$4:$E$103;0));SIERREUR(INDEX(BG!$A$4:$A$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);BG!$B$4:$B$103&BG!$C$4:$C$103&BG!$D$4:$D$103&BG!$E$4:$E$103;0));SIERREUR(INDEX(MF!$A$4:$A$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);MF!$B$4:$B$103&MF!$C$4:$C$103&MF!$D$4:$D$103&MF!$E$4:$E$103;0));SIERREUR(INDEX(MG!$A$4:$A$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);MG!$B$4:$B$103&MG!$C$4:$C$103&MG!$D$4:$D$103&MG!$E$4:$E$103;0));SIERREUR(INDEX(CG!$A$4:$A$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);CG!$B$4:$B$103&CG!$C$4:$C$103&CG!$D$4:$D$103&CG!$E$4:$E$103;0));SIERREUR(INDEX(CF!$A$4:$A$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);CG!$B$4:$B$103&CF!$C$4:$C$103&CF!$D$4:$D$103&CF!$E$4:$E$103;0));0))))))

En “H3”

=SIERREUR(INDEX(BF!$F$4:$F$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);BF!$B$4:$B$103&BF!$C$4:$C$103&BF!$D$4:$D$103&BF!$E$4:$E$103;0));SIERREUR(INDEX(BG!$F$4:$F$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);BG!$B$4:$B$103&BG!$C$4:$C$103&BG!$D$4:$D$103&BG!$E$4:$E$103;0));SIERREUR(INDEX(MF!$F$4:$F$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);MF!$B$4:$B$103&MF!$C$4:$C$103&MF!$D$4:$D$103&MF!$E$4:$E$103;0));SIERREUR(INDEX(MG!$F$4:$F$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);MG!$B$4:$B$103&MG!$C$4:$C$103&MG!$D$4:$D$103&MG!$E$4:$E$103;0));SIERREUR(INDEX(CG!$F$4:$F$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);CG!$B$4:$B$103&CG!$C$4:$C$103&CG!$D$4:$D$103&CG!$E$4:$E$103;0));SIERREUR(INDEX(CF!$F$4:$F$103;EQUIV($A3&$C3&$D3&DROITE($A$1;2);CG!$B$4:$B$103&CF!$C$4:$C$103&CF!$D$4:$D$103&CF!$E$4:$E$103;0));0))))))

Les 2 formules sont matricielles a valider avec ctrl + maj + entrée

Tirer vers le bas autant que nécessaire.

Fichier en retour ICI==> logiciel cross 2017-2018 V1.xlsx (238,9 Ko)

Cordialement.

1 J'aime

Bonjour MDO 100,
je ne peux que te dire MERCI pour ton aide précieuse.

Cordialement
nathalietimon

Bonjour,
Salut MDO,

Là tu fait fort,
Ne me dit pas qu’en VBA tu ne pourrais me faire la même :+1:

Moi, je dis, Oui c’est possible, et facilement
Une petite astuce que je mettrai en oeuvre dans EXERCICE :wink:

1 J'aime

Re Mimimathy,

T’as vu un p’neu :upside_down_face: à peine plus long que la mortier du quart d’un demi dictionnaire Larousse :joy:

Là par contre tu me surestime, je n’arrive même pas a finir ton Exercice N°2.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.