Probleme NB SI ENS

Bonjour à toutes et à tous,

Je crée un tableau pour rechercher combien de mes patients habitants un certain nombre de kilomètre participent ou ne participent pas a des ateliers. le total est de plus de 120 et ça ne correspond pas dans les cases (tableau gris du haut)

Je vois pas mon erreur dans la formule, quelqu’un peut il m’aider :confused:

Merciiii

je joins le fichier : Lieu Habitation Patients Inclus.xlsx (20,5 Ko)

Bonjour @maxoupicsou,

En “F2”

=SOMMEPROD(($A$2:$A$121=$E2)*($B$2:$B$121=F$1))

Tirer vers le bas et vers la droite autant que nécessaire.

Cordialement.

2 J'aimes

Salut MDO

Le :star_struck: de la bonne formule

Comme d’hab. CLAIR - NET - PRECIS

Merci beaucoup :wink:

Toujours de bons conseils :smiley:

Re, bonjour,

Je trouvais “bizarre” le fait de ne pas faire la formule avec NB.SI.ENS() :thinking:

Mais OUI, il faut procéder comme ceci:
=NB.SI.ENS($A:$A;"*"&$E2&"*";$B:$B;"*"&F$1&"*")

Et pour parfaire la belle formule de MDO, au cas d’ajout dans les colonnes A & B
=SOMMEPROD(($A:$A=$E2)*($B:$B=F$1))

1 J'aime