PROBLEME FORMULAIRE avec SIERREUR

bonjour
je suis trésorier d’une association
je cherche comment automatiser les formulaires d’appels de cotisations.
je pars de la banque. les membres règlent quand ils veulent. 1 fois par mois ou 1 fois par trimestre.
dans mon formulaire d’appel, je reporte à la mains les lignes de paiement.
je cherche à automatiser cela.
j’ai fais un test avec cette formule :
=SIERREUR(EQUIV($B$7;DECALER(Banque!$D$1;A27;0;NBVAL(Banque!B:B)-A27;1);0)+A27;"")
mais si un membre règle en 1 fois au lieu de 3 j’ai des lignes vides.
je dois les supprimer ou les ajouter manuellement.
je cherche comment automatiser tout celà.
je voudrais insérer la ligne d’appel de cotisation en fonction de la date du jour et insérer la/les lignes de paiement quand je les saisie en banque
voici mon exemple.
Comptes 2020-103.xlsx (35,0 Ko)
merci d’avance

Bonjour,

Une proposition avec TCD et colonnes cachées.
Comptes 2020-103.xlsx (86,1 Ko)
Cordialement.

merci Zebulon
c’est génial !!!

Bonjour,
Content que cela te convienne.
Cordialement.