Problème fonction sur plage de cellule et intervalle

Bonjour,
j’ai un problème que je n’arrive pas à résoudre pour faire une recherche dans un fichier EXCEL destiné à de l’archivage.
le fichier ce comporte ainsi :
COLONNE 1 / COLONNE 2 / COLONNE 3 / COLONNE 4
carton / client 1 / numéro dossier min / numéro de dossier max.

Pour être plus concret, les valeur peuvent être les suivantes :
1A / CLIENT 1 / 17100 / 18100
1B / CLIENT 2 / 17200 / 17600
1C / CLIENT 1 / 18101 / 18500
1D / CLIENT 3 / 17150 / 17800

je voudrais pouvoir avec seulement deux informations : nom du client et numéro de dossier une formule qui me donne le numéro du carton dans lequel le dossier est rangé.
Les dossiers sont en ordre croissant mais triés par client
Exemple : 17100 / CLIENT 1 / 17101 CLIENT 2 / 17102 CLIENT 3 / 17103 CLIENT 1.

Merci pour votre aide.

Bonjour ;

Merci de bien détailler votre problème en insérant un fichier exemple.

Salutations.

1 J'aime

pardon, j’ai lancé ma question avant d’avoir fini de l’écrire.
Dite moi si c’est plus clair.

Bonjour,

Pour être plus concret
image

EXEMPLE.xls (7 Ko)

Je vous transmets un fichier exemple.
Il faudrait croiser avec la formule ET l’information du nom du client et aussi que sont dossier soit compris entre l’intervalle de dossier afin que le numéro de carton sorte automatiquement.
Je n’arrive pas à indiquer de fonction qui me donnerait une valeur comprise dans un intervalle.

Bonjour,

Un essai avec formule matricielle (A valider par les touches CTRL MAJ ENTREE)
Si aucune correspondance “***”

=SIERREUR(INDEX(C7:C11;EQUIV(1;(B7:B11=B4)*(D7:D11<=C4)*(E7:E11>=C4);0));"***")

EXEMPLE.xls (21,5 Ko)