Probleme avec un tableau de prix degressifs

Bonsoir le Forum !

Alors voila,
Depuis maintenant quelques heures j’essaye d’introduire une formule dans ma ligne pour calculer des résultats, je vous explique.

Je fait un tableau qui doit calculer automatiquement un prix en fonction du poids renseigné.

J’aimerais que ma cellule G5 montre le calcul G5+65 en fonction du poids le plus haut.

Si cellule A5 entre 51et 200 le prix de la cellule G5 devrait être : C5+65
Si A5 entre 200 et 300 le prix : G5 = d5+65
Si A5 entre 301 et 600 le prix : G5 = e5+65

j’ai tenté entre autres la formule :=SI(A5>51;A5<200);C5+65
mais ça m’affiche le fameux #NAME?

Si quelqu’un a une idée je suis preneur =)

Merci d’avance !

Bonjour,
La syntaxe ne semble pas bonne, je pense que quelque chose comme ça devrait aller :
=SI(ET(A5>=51;A5<200);C5+65;SI(ET(A5>=200;A5<300);D5+65;SI(ET(A5>=300;A5<600);E5+65)))

Bonjour ,
=SI(A5>600;F5+65;SI(A5>300;E5+65;SI(A5>200;D5+65;SI(A5>50;C5+65;A5+65))))
Bon courage

Bonjour,

Malheureusement les 2 propositions ne marchent pas = /

Je ne sais plus trop quoi tenter en plus

Cordialement.

Bonjour,

Ci-joint un fichier test. Cela convient-il ?poids le plus haut.xlsx (9,3 Ko)

1 J'aime

Çà marche !

Merci beaucoup =)

Cordialement

Re bonjour,

Je sais pas si je devrais re faire un sujet ou pas mais j’ai un autre petit soucis.

J’aimerais que en écrivant “O” dans une case le calcule d’une autre soit le suivant :

Si F5=O alors G13+20 puis ce résultat +11%

Si F5 = N alors G13+11%

J’ai tenté =Si(F5=“O”;G13+20) juste pour voir si ca peut marcher mais la cellule affiche #NAME?

Auriez vous une solution ?

d’avance merci beaucoup !

Je pense que cette formule devrait convenir :
=SI(F5=“O”;(G13+20)*1,11;SI(F5=“N”;G13*1,11;""))
Attention : la recopie de la formule du post modifie les guillemets.

PS : le mieux c’est toujours de joindre le fichier plutôt qu’une copie d’écran.

Malheureusement ça ne marche pas ou je ne sais pas le faire marcher

Effectivement je pense qu’avec le fichier ce sera plus compréhensible désolé !

Calculatrice prix B.xlsx (21,1 Ko)

L’idée est c’est d’avoir un prix total (H) en fonction de la taille du poids entré.
Le “Total” (H) doit est un calcul de G+11%, si dans la cellule F5 le “O” est présent le calcul total doit être G+20+11%.
Si la cellule est vide ou le “N” est présent le calcul doit être G+11%.

Merci

Bonsoir,

Dans votre fichier, tous les guillemets n’ont pas été remplacé.
Cela convient-il ?
Estim-trvx V2.xlsx (21,0 Ko)

1 J'aime

Monsieur !

Merci pour tout.

Excellente journée à vous.

Cordialement

Presque ! c’est peut-être madame :wink: