Prévisionnel de trésorerie (Total des mensualités entre date)

Bonjour tout le monde, je ne sais pas comment m’y prendre pour calculer le total par mois de plusieurs mensualités avec Excel en fonction de la date de debut et fin.

Pour expliquer plus précisément, je cherche à faire une liste de crédit, contenant le montant mensuel, la date de début et la date de fin.
J’ai ensuite fait une liste de mois sur plusieurs années pour essayer de totaliser les mensualités dans la colonne d’à coté, mais c’est là que ça pêche.

J’ai essayé en simplifiant ma formule pour simplement totaliser les lignes de la colonne si la date de fin et supérieur à la date du mois ou je souhaite obtenir le resultat, mais ca ne fontionne pas correctement.

Voir l’imprim ecran ci-dessous.
Merci pour votre aide.

Bonjour,

pour nous aider à mieux vous aider, partagez votre fichier (sans données confidentielles) :wink:

Une piste déjà : ($E$2:$E) ne peut fonctionner.
Il faut écrire ($E$2:$E$1000) par exemple

Bonjour, merci pour votre retour.
Sur Google Sheet la recherche E2:E fonctionne bien.

Normalement mon fichier ci-dessous est public.

Cordialement.
Vincent

à essayer :

=SOMMEPROD(($E$2:$E>=$G2)*$C$2:$C)

Mais je vous conseille :
=SOMMEPROD(($E$2:$E$1000>=$G2)*$C$2:$C$1000)

Au cas où un jour vous utilisiez Excel plutôt que Google Sheets :wink:

Votre fichier étant en lecture seule, je n’ai pu tester la formule

Bonjour, merci pour votre retour, SOMMEPROD, fonctionne effectivement très bien.
Je ne connaissais pas cette formule.