Pb rechercheV / index-equiv qui ne fonctionne pas


#1

Bonjour,
j’avais un problème de recherchev qui ne fonctionne pas dans un gros excel.
Aprés avoir cherché, j’ai compris qu’il fallait que je passe a index/equiv plus adapté a ma recherche, mais je n’arrive pas a le mettre en place.

toujours pour debugger, je suis reparti d’un nouveau classeur tout bete, dans lequel j’ai mis:
en A1 la valeur tata
de C1 a C5 les chiffres de 1 à 5
en D3 tata

et la formule =INDEX(C1:C5;EQUIV(A1;C1:D5;0)) en F1 ; et ça ne marche pas puisque ça me sort #N/A
help !

test.xlsx (8,6 Ko)


#2

Bonjour,

Teste comme ceci

=INDEX(C1:C5;EQUIV(A1;D1:D5;0))

#3

bonjour,
merci, ça marche sur mon exemple. mais quand je le reporte sur mon gros excel, ça ne marche plus, j’ai toujours #N/A
faut il qu’une colonne soit triée pour que cela fonctionne ?


#4

Bonjour, si tu reporte la formule vers le bas, c’est normal,
Si l’exemple fourni n’est pas configuré comme il faut le reproduire :face_with_raised_eyebrow:

=INDEX($C$1:$C$5;EQUIV(A1;$D$1:$D$5;0))

avec les “$” pour bloquer les plages, cela devrait être bon.


#5

non, non ça n’est pas le report de cellule vers le bas qui ne fonctionne pas.
c’est juste la formule utilisée dans l’exemple que je reporte dans mon gros classeur, en adaptant les plages. j’ai verifié les formats de celulle qui sont identiques.

mais j’ai laissé tombé: je traite manuellement, pas le temps de debugger excel.


#6

Re,
Juste pour voir,
place un bout de ton classeur sans données confidentielles