Nombre d'occurrences dans plusieurs plages


#1

Bonjour à tous,
pourriez vous me dire comment je pourrais compter le nombre d’occurrences dans plusieurs plages et non une seule ?

Merci de votre aide :slightly_smiling_face:


#2

Bonjour
Pour un petit nombre de plages, une somme de fonctions NB.SI ?


#3

Merci DocteurExcel,

mais je n’arrive pas à sélectionner des plages distinctes avec cette fonction.
Y aurait il une autre fonction qui permette de sélectionner des plages distinctes et de tailles différentes ?

Merci bien :slightly_smiling_face:


#4

C’est surement possible mais difficile de se prononcer sans voir un fichier d’exemple!
Pourrais-tu en joindre a ta question stp?


#5

Oui, je cherche à savoir combien Lucie a de gardes dans le mois de mai et combien de matinées ?
Merci bien.Exemple.xlsx (11,6 Ko)


#6

Bonjour @Rainui,
Salut @DocteurExcel,

Pour commencer un petit conseil, il faut éviter autant que possible de fusionner des cellules dans un tableau, car souvent c’est une source d’erreur pour les calculs.

Dans le cas présent, c’est une complication pour réaliser la formule, déjà bien longue, je ne suis pas parvenu à la réduire plus.

J’ai donc dé-fusionné toutes les cellules.

Ne sachant pas ou doivent commencer les résultats, je les ais mis à partir de la cellule “C22” et pour quelle fonctionne avec d’autres noms, il faut aussi renseigner le nom en “A22” et (Matinée ou Garde) en “B22”.

Bien entendu, tout ça peut-être déporté dans une autre feuille pour plus de clarté.

Formule en “C22”

=SOMMEPROD(($B$1:$B$20=B22)*($C$1:$C$20=A22))+
SOMMEPROD(($D$1:$D$20=B22)*($E$1:$E$20=A22))+
SOMMEPROD(($F$1:$F$20=B22)*($G$1:$G$20=A22))+
SOMMEPROD(($H$1:$H$20=B22)*($I$1:$I$20=A22))+
SOMMEPROD(($J$1:$J$20=B22)*($K$1:$K$20=A22))+
SOMMEPROD(($L$1:$L$20=B22)*($M$1:$M$20=A22))+
SOMMEPROD(($N$1:$N$20=B22)*($O$1:$O$20=A22))

Tirer vers le bas autant que nécessaire.

Ton fichier en retour ICI==> Rainui V1.xlsx (15,3 Ko)

Cordialement.


#7

Merci infiniment pour cette aide précieuse @mdo100
Merci à vous deux d’avoir pris du temps pour ma question @DocteurExcel @mdo100

Cordialement :blush:


#8

Re @Rainui,

Si ton probleme est resolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Merci