✅ Ne pas prendre en compte une formule avec "SI" si le résultat est négatif


#1

Bonjour,
Je voudrais rentrer la formule qui choisi la réduction fillon correcte en fonction du FNAL s’il est à 0.50 ou à 0.10 dans mon tableau, jusque la tout va bien, mais je ne sais pas comment lui dire que si le résultat du coefficient est négatif alors ne rien calculer, mettre à 0 quoi !

Ma formule est : =SI(I12>0;(0,2849/0,6)(1,6(G4/G1)-1);(0,2809/0,6)(1,6(G4/G1)-1))

sur I12 il y a une formule et donc j’ai soit un montant soit rien selon si le FNAL est à 0.50 ou à 0.10 pour un cas de figure.
Donc s’il n’y a pas de montant, on prend la première formule avec 0.2849 sinon on prend la seconde avec 0.2809.

A partir de là, comment fait on pour lui dire que si le résultat est négatif (-0.36 si le calcul se fait normalement par ex) il faut ramener le résultat à 0 sinon il va me calculer un salaire brut avec un coefficient qui est erroné et me faire une déduction sur les charges patronales auquelles je n’ai pas droit.

Merci d’avance,


#2

Hello
Peux tu ajouter un fichier stp pour que l’on comprenne bien ton problème ?


#3

fillon.xlsx (11,8 Ko)

Le voici, J’espère que vous comprendrez mieux, j’ai supprimé ce qui ne servait pas à ma question, du coup le I12 a changé de ligne !!!
Vous avez la formule que j’ai tapé pour l’instant en jaune pour laquelle je voudrais qu’elle apparaisse à 0 quand le résultat est négatif comme ici.
Merci d’avance de votre aide.
Véronique


#4

Bonsoir

Pour avoir zéro comme résultat si une formule renvoie un résultat négatif, tu peux utiliser:
=MAX(0;ta_formule)

Donc dans ton cas
=MAX(0;SI(I9>0;(0,2849/0,6)(1,6(G4/G1)-1);(0,2809/0,6)(1,6(G4/G1)-1)))

fillon.xlsx (12,5 Ko)


#5

Bonjour,
Merci beaucoup pour votre aide, je ne connaissais pas cette fonction !
ça fonctionne !