INDEX & EQUIV avec CONDITION issue d'un tableau & d'un TCD


#1

Bonjour,

Je cherche à bâtir un tableau de bord dans lequel j’ai par mois :

  • soit le € HTVA et la mission issus du PRÉVISIONNEL

  • soit le € HTVA et la mission de la VENTE issus de la COMPTA.

S’il y a VENTE, il n’y a plus de PRÉVISIONNEL.

Ci-joint un fichier.

Dans la partie base de l’onglet TABLEAU DE BORD, le tableau idéal que je souhaite bâtir automatique.

Reste à votre disposition et par avance merci de votre aide.

Cordialement.
Exercice.xlsm (144,2 Ko)


#2

Bonjour @Cannamella,

Regarde si cela peut convenir à ta demande.

Je l’ais juste fait pour le mois de juillet, je te laisse adapter les formules et donc faire le reste.

En “AF5”: Formule matricielle a valider avec ctrl + maj + entrée

=SIERREUR(INDEX(VENTES!$F$4:$F$19;EQUIV($C5&AD$3;VENTES!$D$4:$D$19&VENTES!$A$4:$A$19;0));"")

En “AG5”: Formule matricielle a valider avec ctrl + maj + entrée

=SIERREUR(INDEX(VENTES!$E$4:$E$19;EQUIV($C5&AD$3;VENTES!$D$4:$D$19&VENTES!$A$4:$A$19;0));"")

Ci-joint ton fichier en retour ICI==> Cannamella V1.xlsm (149,9 Ko)

Cordialement.