Formules SI Imbriquées

Bonjour,

J’ai de nouveau une question concernant l’imbrication d’une formule SI sur Excel.

Je souhaiterai écrire une formule avec les critères suivants :

  • Augmentation si plus de 3 mois d’ancienneté au 30/01/2018
  • Augmentation hors qualification CADRE et HMAIT
  • 20 euros si salaire < 1651 ; 16 euros si salaire compris entre ]1650, 1800]; 15 euros si > 1800.

Exemple.xlsx (10,8 Ko)

J’ai fait la formule suivante : SI(ET(B2<>“CADRE”;B2<>“HMAIT”; DATEDIF(D2;“30/01/2018”;“m”)>3);SI(C2<1651;20;SI(ET(C2>1650;C2<1801);16;SI(C2>1800;15;0))))

Le problème est qu’elle renvoie FAUX au lieu de “0” euros lorsque les critères ne sont pas respectés (voir fichier exemple ci-joint).
Également, y a t’il moyen d’optimiser l’écriture de ma formule?

Bien cordialement,

Charlotte

Bonjour,

C’était presque bon, simplement tu n’avais mis le “0” au bon endroit. Il faut le mettre si la condition est fausse du premier SI().
Il y avait aussi les sommes qui se confondaient. Bien respecter les Sup, Inf, Sup ou égal, etc.

=SI(ET(B2<>"CADRE";B2<>"HMAIT"; DATEDIF(D2;"30/01/2018";"m")>3);SI(C2>=1800;15;SI(ET(C2>=1650;C2<1800);16;SI(C2<1650;20)));0)
1 J'aime

Je vous remercie ! Cette formule marche bien :slight_smile:

1 J'aime