Formules pour incrémenter indice si plusieurs conditions


#1

Bonjour à tous, je suis nouveau sur le forum et pardonnez moi d’avance pour mes erreurs éventuelles de Post !
Voilà mon souci, je cherche à faire évoluer un indice représenté par une lettre en colonne A dans la colonne C en fonction de la valeur entrée en colonne B.
En gros:
Si B4 = valeur 1 et A4 = “A” alors C4 = “B” sinon C4 = A4; Si A4 = “B” alors “C” sinon C4 = A4 ; Si A4 = “C” alors “D” sinon C4 = A4; etc…

Passage d’indice Essai.xlsx (10,6 Ko)


#2

Bonsoir @Ouam85,

Si j’ai bien compris, regarde si cela te convient:

En “C4”

=SI(ET(B4=1;A4=CAR(CODE(A4)-LIGNE()+LIGNE()));CAR(CODE(A4)-LIGNE()+LIGNE()+1);A4)

Puis tirer vers le bas autant que nécessaire.

Ton fichier en retour ICI==> Ouam85 Passage d’indice V1.xlsx (12,4 Ko)

Cordialement.


#3

Super, c’est exactement le résultat que je souhaitais !!!
Un grand Merci !


#4

Re @Ouam85,

Très bien, si ton problème est résolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Cdlt.