Formule SIERREUR ne fonctionne pas


#1

Bonjour,

Pourriez-vous me renseigner sur le résultat renvoyé lorsque j’utilise la formule SIERREUR?
Je calcul en valeur absolue l’écart relatif entre les cours obtenu entre fin Novembre et fin Octobre 2017. J’obtiens donc un %.
Néanmoins si j’ai du texte à la place de chiffre, j’obtiens le résultat #VALEUR!
Pour le corriger le pensais utiliser la formule SIERREUR. Et écrire = SIERREUR (ABS(Fin Nov-Fin Oct/FIn Oct);" ")
A fin que si le #VALEUR! disparaisse…

		Cours à fin Nov 2017	Cours à fin Oct 2017	Ecart relatif

ASSO FR0000296592 FG ACTIONS 493,28 480,13 2,67%
ASSO FR0000981425 ECOFI MONEDYM Clos au 28.02.17 Clos au 28.02.17 #VALEUR!
ASSO FR0000983744 CA MONE J FCP 3DEC Fonds dissous le 17.06.14 Fonds dissous le 17.06.14 #VALEUR!
COOP FR0007481908 INV PLUS DIVERSIFIE Renseigné par DAO Renseigné par DAO #VALEUR!
ASSO FR0010095893 BTP ASSO C Fonds dissous le 20.04.17 Fonds dissous le 20.04.17 #VALEUR!
ASSO FR0010127480 VAUGIRARD TAUX ABSOLUS 27 179,37 26 865,78 1,15%

Mais j’obtiens le résultat suivant:

		Cours à fin Nov 2017	Cours à fin Oct 2017	Ecart relatif

ASSO FR0000296592 FG ACTIONS 493,28 480,13 #NOM?
ASSO FR0000981425 ECOFI MONEDYM Clos au 28.02.17 Clos au 28.02.17 #NOM?
ASSO FR0000983744 CA MONE J FCP 3DEC Fonds dissous le 17.06.14 Fonds dissous le 17.06.14 #NOM?
COOP FR0007481908 INV PLUS DIVERSIFIE Renseigné par DAO Renseigné par DAO #NOM?
ASSO FR0010095893 BTP ASSO C Fonds dissous le 20.04.17 Fonds dissous le 20.04.17 #NOM?
ASSO FR0010127480 VAUGIRARD TAUX ABSOLUS 27 179,37 26 865,78 #NOM?

#NOM? à chaque fois!? J’ai compris qu’il y a une erreur dans la synthaxe par rapport au résultat renvoyé mais laquelle?

De plus, sauf erreur, lorsque je tape le début de la formule =SIERREUR(… Excel ne me propose pas la synthaxe de la formule…?

Merci pour votre aide!


#2

Bonjour!

Je ne suis pas sur d’avoir bien compris ta question.
Pourrais tu nous donner plus de détails stp et si possible inclure un fichier d’exemple?

Merci et à bientôt


#3

Bonjour Docteur Excel,

Merci pour l’aide! Je te joins le fichier Excel intégrant les formules… C’est vrai que c’est plus simple pour lire.

D’avance merciFormule SIERREUR.xls (38,5 Ko)


#4

As-tu plus d’explications également car je n’ai pas vraiment compris ta question à vrai dire…


#5

Bonjour @11946356, @DocteurExcel,

@11946356, ta version d’Excel ne doit pas disposer de la fonction “SIERREUR”, pour remédier à ce problème je te propose d’utiliser la fonction “ESTERREUR”.

Ce qui donnerait sur ton fichier en:

“F2”:

=SI(ESTERREUR(ABS((E2-D2)/D2));"";ABS((E2-D2)/D2))

Tirer vers le bas autant que nécessaire.

Peux-tu nous confirmer ta version d’Excel ?

Cordialement.


#6

Bonjour mdo100

Merci pour tes explications. J’ai essayé d’appliquer ta formule mais Excel m’indique toujours qu’il y a une erreur au niveau de la formule utilisée en pointant sur les espaces " "
Finalement lorque tu m’a posé la question de la version d’EXcel j’ai ouvert mon fichier avec Excel 2010 et là ma formule avec SIERREUR fonctionne normalement…

Merci à vous! Désolé je n’avais pas pensé au problème de version…


#7

En fait c’était un problème de version! En ouvrant mon fichier avec Excel 2010 ma formule avec SIERREUR fonctionne normalement…
Je ne comprennais pas pour Excel ne me proposait pas la formule SIERREUR dans le menu déroulant des formules proposées…
De plus il m’indiquait constamant un problème de synthaxe… Normal puisque j’étais dans une mauvaise version…

Merci Docteur!