Formule =si fonctionne avec des lettres mais FAUX avec des nombres

salut, je me permet de vous demander de l’aide, je suis débutant en Excel et je suis coincé avec une formule qui marche dans un cas et pas dans un autre, je précise, j’ai un tableau, ligne :A1 article , B1 nombre d’heure , C1 matricule , D1 rendement réel , E1 moyenne article/heure et, dans la colonne A il y’a cinq article de produit" 20 " et cinq du " 21 " de (A2 :A13).
Je veux calculer la moyenne article par heure, alors j’ai débuté par calculer la somme du rendement réel de l’article « 20 » par cette formule =SOMME.SI(A2:A13;« 20 »;D2:D13) = 138
et l’article « 21 » par =SOMME.SI(A2:A13;« 21 »;D2:D13) = 772.
Et aussi le nombre d’heure effectué par article : =SOMME.SI(A2:A13;« 20 »;B2:B13) = 18 et =SOMME.SI(A2:A13;« 21 »;B2:B13) = 24 donc la moyenne article par heure de produit « 20 » et 138 /18 = 7.76 et du produit « 21 » 772/24 = 32.17…
et pour afficher les résultats dans les cellules correspondantes il me fallait une formule.
Dans la colonne A J’ai mis la lettre « a » à la place du produit « 20 » et la lettre « b » à la place du produit « 21 » et dans la cellule E2 j’ai mis cette formule
=SI(A$2:A$13=« a »;« 6,67 »;SI(A$2:A$13=« b »;« 32,17 »)) ca a marchait très bien
mais quand j’ai rendu les « 20 » et « 21 » à leurs place dans la colonne A, et j’ai mis la formule =SI(A$2:A$13=« 20 »;« 6,67 »;SI(A$2:A$13=« 21 »;« 32,17 »)) ca n’a pas marchais, résultat « FAUX »
Si Quelqu’un peut m’aider à corriger et à comprendre pourquoi s’il vous plait !! pourquoi c’est correcte avec les lettres et faux avec les nombres ?
Merci d’avance.
formule =si0.xlsx (10,5 Ko) formule =si1.xlsx (10,6 Ko)

Bonjour

Pas de guillemets autour des chiffres

=SI(A$2:A$13=20;6,67;SI(A$2:A$13=21;32,17))
1 J'aime

Bonjour
ça a marché très bien
je ne sais pas comment vous remercier, MERCI INFINIMENT,
personne ne peut vivre seul !!! on ai tjrs besoin de quelqu’un !

Rebonjour,
une remarque s’il vous plait , pourquoi les guillemets marche dans les formules =somme.si des cellules B14,B15 et D14,D15 ? et pas dans la formule de cellule E2 ?? merci d’avance…

Re,
Dans cette condition, le 20 ou 21 est un critère et non une égalité
mais il aurait été préférable d’ôter aussi les guillemets
D’ailleurs pour les formules en colonne E, si les égalités sont 20 ou 21, la formule peut-être simplifiée par :

=SI(A2="";"";SI(A2=20;6,67;32,17))
1 J'aime

merci beaucoup, s’il y a d’autre produit exemple « 22 » et « 23 » je crois que c’est préférable de laisser la première formule non ??

=SI(A$2:A$13=20;6,67;SI(A$2:A$13=21;32,17;SI(A$2:A$13=22;3,5;SI(A$2:A$13=23;3))))

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.