Formule permettant d'obtenir une valeur résultant de deux critères


#1

Bonjour,
Je recherche une formule Excel permettant d’obtenir une valeur résultante de deux critères.

Dans un premier tableau, j’ai :
En abscisse, j’ai le type de bien : bureau/ entrepôt/ local d’activité
En ordonnée, j’ai la taille de la ville : grande/ moyenne/ petite
A la croisée de chaque type de bien et chaque type de ville correspond une valeur, en l’occurence un prix/ m²

Dans un second tableau, j’ai une liste de biens et je saisis dans deux colonnes distinctes le type de bien et le type de ville
Dans ce même tableau, je souhaiterais dans la troisième colonne obtenir la valeur correspondante

Exemple : si mon bien est un entrepôt dans une ville moyenne, la valeur est de 50

Merci !

Je suis joignable par téléphone si pas clair.

Guillaume


#2

Bonjour,

Cela serait plus clair avec un classeur exemple sur EXCEL :wink:


#3

je ne trouve pas la possibilité de transmettre le tableau en PJ ?


#4

Bonjour @Guillaume_THERIEZ, @Mimimathy,

Pour joindre un fichier, suivre la procédure ci-dessous:

Joindre un fichier

@+
Cordialement.


#5

Calculs.xlsx (10,2 Ko)


#6

merci ! effectivement je n’avais pas vu l’icône; nos messages se sont croisés


#7

C’est du croisé dynamique ou c’est plus simple ?


#8

Re @Guillaume_THERIEZ,

Voici une proposition:

En “I4”

=SIERREUR(INDEX($C$4:$E$6;EQUIV($G4;$B$4:$B$6;0);EQUIV($H4;$C$2:$E$2;0));"")

Formule matricielle à valider avec ctrl + maj + entrée
Puis tirer vers le bas autant que nécessaire.

Ton fichier en retour ICI==> Guillaume_THERIEZ V1.xlsx (12,0 Ko)

Cordialement.


#9

merci beaucoup je teste et te tiens au courant de suite


#10

mdo100 merci beaucoup c’est vraiment top !
Je ne sais pas comment votre cerveau est configuré pour trouver ce type de formule mais cela faisait trois heures que je galérais sans aucun résultat; et je connais pourtant bien Excel !
Un grande merci, tu vas me faire gagner quasiment deux jours ! j’ai 1 200 biens à estimer !

Guillaume