Formule excel pour calcul de temps excluant tout écart de plus de 10min


#1

Bonjour tout est dans le titre , on a des fichiers au boulot qu’on appelle horodatage ( Avec les heures successives en colonne ds excel de chaque relevé de compteur effectué par nos releveur ) et quand on calcule leurs temps de travail , on doit exclure tout écart de plus de 10min entre deux relevés . Serait-il possible de fournir une formule type qui nous permettrai de ne plus faire ce fastidieux calcul de tête ?


#2

Bonjour @Pauline_Lina_T
Peux tu joindre un fichier d’exemple stp?


#3

exemple horodatage.xlsx (8,1 Ko)

Voila pour l’exemple du fichier , le calcul serait 12 min une pause puis 2 min (on ne comptabilise pas les secondes) , donc 14 min soit en décimal environ 0,25 . Une formule pourrait elle aboutir au 0,25 (voir au résultat décimal précis ) ?

Merci d’avance pour votre aide :blush:


#4

Bonjour
Tout d’abord il sera plus pratique d’écrire les heures avec un format d’heures dance Excel en utilisant les 2 points : 00:00:00

Cela te permet de faire des opérations sur les heures et également que le résultat soit exprimé en heures minutes et secondes avec le même format

Ensuite tu peux utiliser la formule suivante:

=SI(B2-B1<10/60/24;B2-B1;0)

afin d’éliminer les durées inférieures à 10 minutes, tu peux ensuite en faire la somme ou toute autre operation

exemple horodatage (1).xlsx (9,0 Ko)


#5

Merci beaucoup pour l’aide docteur excel :hugs: