Formule excel compliquee

Bonsoir
je viens ici car j’ai besoin de votre aide pour une fonction que je ne trouve pas.
mon problème:
Le dois récuoérer des valeurs dans un fichier.
j’y suis presque mais une condition n’est pas remplie
voici les conditions
1° le texte de la colonne F doit être le même
2° on récupère en colonne J la somme des valeurs séléxtionnées en M à partir de la condition1
3° la formuke n’est activée que lorsque un valeur (40 ,60 ou 80 ) est indiquée en colonne G
Je sais, c’est compliqué et je joins un fichier explicatif expurgé en espérant que c’est explicite.
VERIFICATIONS 6.xlsx (22,2 Ko)

Salut,

C’était pas déjà ici ?

1 J'aime

ERREUR nono
mon problème n’a pas été réglé par " celui qui a toutes les compétences " comme tu dis .
je pense qu’i a fait le maxi, mais devant mes difficultés il m’a proposé de voir avec quelqu’un qui puisse m’expliquer;c’est du moins ce que j’ai compris.
bien sur, il n’y a aucun problème avec ce spécialiste que je n’ai pas manqué de remercier pour son aide;
comme tu le vois, il n’y a aucun manque de respect , bien au contraire.
Donc, tu connais mainten

maintenant le problème et je t’invite si tu le veux (a moins que quelqu’un d 'autre puisse le faire) à m’indiquer et si possible m’expliquer succintement la formule .après, je pourrai me débrouiller
Bonne soirée

1 J'aime

Bonsoir @belambra,
Salut @Nono, :wink:

Bon je ne promets aucun résultat :bangbang:

Par contre on va reprendre à zéro, tes explications sont insuffisantes.
Reformule ta demande comme si nous partions de rien, sois explicite et précis.
Et sois patient pour la réponse, inutile dans un premier temps de multiplier la demande de forum en forum.

Cordialement.

OK et bonsoir
Voici mon peoblème:
je veux récuoérer dans la colonne J des valeurs de la colonne M, mais ceci avec conditions:
Sur les lignes de la colonne F , se trouvent un N° de lot ( ex JEAN S03 2018) , la colonne M une VALEUR
lES valeurs à récupérer sont uniquement celles ayant en colonne F et sur la même ligne , la même indication
De plus il doit y avoir en colonne J t sur la même ligne, ( une valeur (40 60 ou 80)
.J’y étais presque, mais la formule a eté modifiée sans explications et je suis complètement paume.
A NOTER QUE LES INDICATIONS EN F DOIVENT ETRE EXACTEMENT LES MEMES
ex dans le fichier joint, il y a confusion avec JEAN S08 2018 et JEAN S08 2017
ERIC S03 2018 ET ERIC S03 2017
C’est ça qui me pose problème, réintégrer les dernieres données(2018 et 2017) dans les indications de la colonne F
Merci de me dire (ou quelqu’un d’autre) si tu peux faire quelque chose.
Je joins un modèle de fichier.
Bonne soirée https://www.cjoint.com/c/HIgs77IjMdA

@belambra,

Je regarderai ça demain aprés un repos bien mérité.
Toutefois:

Bonne soirée également.

Bonjour @belambra,

Je ne sais pas si j’ai bien tout saisie de la demande:

Alors regarde le fichier joint, dans les nouvelles colonnes “P, Q, R, S, T” si cela correspond a ce que tu souhaites obtenir comme résultat.

Fichier ICI==> belambra V1.xlsx (52,5 Ko)

Cordialement.

Bonsoir
je me suis mal expliqué.
En fait il faut juste modifier la formule de echerche de “com déjà versée” car la formule que j’ai n’intègre pas les 4 derniers chifres de la colonne F aInsi, dans F il faut faire la distinction entre JEAN S03 2018 et JEAN S03 2017;*
Ma formule ne fait pas cette distinction
Possibilité de modifier?VERIFICATIONS 6.xlsx (24,0 Ko)
SI difficultés, quelqu’un d’autre peut peut être participer
j’ai essayé avec RECHERCHEV mais je n’y arrive pas
Bonne soirée

Bonjour @belambra,

Voici une proposition si j’ai bien compris et ce n’ai pas de la tarte.

En “J7”

=SI(G7<>"";SOMMEPROD((SUBSTITUE($F$5:$F5;DROITE($F$5:$F5;4);"")&DROITE($F$5:$F5;1)=SUBSTITUE($F6;DROITE($F6;4);"")&DROITE(F6;1))*$M$6:$M6);"")

Tirer vers le bas autant que nécessaire.

Ton fichier en retour ICI==> VERIFICATIONS belambra.xlsx (26,4 Ko)

Cordialement.

Bonjour
Je crois que c’est bon. je vais maintenant essayer avec mon fichier complet et ne manque rai pas de te tenir au courant .Effectivement , c’est compliqué
En attendant, grand merci

Bonjour
C’est parfait;
encore merci pour ton aide
un autre petit problème qui pour toi sera facile à régler
mon fichier a plus de 3000 lignes et je veux eviter du copié/collé cellule par cellule si possible.j’y arrive pas
je joins un fichier explicatif
en fait, je voudrais recopier une formule de cellule dans certaVERIFICATIONS 8.xlsx (15,4 Ko)
ines cellules seulement en tenant compte de conditions

Bonjour @belambra,

Tes explications ne sont pas claires et je ne te parle même pas de tes fichiers qui sont mal fichus.

Bref de ce que j’ai compris la fonction “SIERREUR” devrait faire l’affaire.

SIERREUR(valeur où formule;valeur si erreur vide “” où 0 )

En “G6”

=SIERREUR(RECHERCHEV(E6;DECALER(base_com!$A$7;0;((F6-40)/20)*4;9;4);3;1);"")

En “H6”

=SIERREUR(G6*E6;"")

En “J6”

=SIERREUR(H6-I6;"")

En “L6”

=SIERREUR(J6+K6;"")

Tirer vers le bas autant que nécessaire.

Les colonnes “I & K” sont des valeurs manuelles, donc il suffit de ne rien y mettre me semble t-il.

Ton fichier en retour ICI==> VERIFICATIONS 8 18 09 2018.xlsx (15,6 Ko)

Cordialement.

Bonjour MOD100
CA y est, Tout est en ordre.
CA FONCTIONNE PARFAITEMENT;
je te remercie encore et te souhaite bonne continuation
cordialement

Bonjour @belambra,

Très bien, content d’avoir pu rendre service :wink:

Si ton problème est résolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Merci.
Cordialement.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.