Formule compris entre deux valeur repport d'un nombre

bonjour voila je suis entrain de me créer un tableau excel pour compté mes heures de travail, notre système de paye étant complexe je veux simplifié au mieux l’entré des données après le tableau finalisé.

je fais 36 heures normal semaines, a cela s’ajouté les heures supp comprise entre 37 et 42 à 125% et de 43 à 48 à 150%.

Dans ma case A1 j’ai mon total d’heures semaines
dans ma case A2 je veux les heures à 125%
dans ma case A3 je veux les heures à 150%

donc je voudrais que automatiquement les case d’heure supp de remplice une fois la donné de la case A1 soit rentré.

Exemple:

A1 - 45,00
A2 - 6,00
A3 - 3,00

Quel serai la formule a utilisé ? j’ai essayer avec les fonction SI OU ET mais je doit mal les utilisés.

merci d’avance pour votre aide

Bonjour,

en A2 : =SI(A1="";"";SI(ET(A1>36;A1<=42);A1-36;6))
En A3 : =SI(A1="";"";SI(A1>42;A1-42;""))

Ces formules fonctionnent en décimal. C’est à dire que si tu saisis ton nombre d’heures en format hh:mm (heures minutes, il faudra adapter les formules en conséquence.

1 J'aime
  • La formule en A2 ne marche pas si je dépasse 36 le chiffre affiche reste 6
    j’ai donc essayer en modifiant la dernière chiffre
    =SI(B27="";"";SI(ET(B27>36;B27<=42);B27-36;"")) mais du coup quad on dépasse les 42 je n’ai pus de chiffre qui si afiche alors que j’aurai bien voulut garder la donnée comprise entre 36 et 42 et ensuite passer sur A3 quand sa va au dessu

la formule en A3 marche très bien. elle décompte bien.

Bonjour,

Pour ma part elle fonctionne bien. Peux-tu m’envoyer le ficier excel ou elle ne fonctionne pas corrctement ?

test calcul nouveau format.xlsx (21,0 Ko)

voila le fichier donc c’est les cellule heure supp 125 et 150 sur le calcul d’une semaine de travail

en effet j’ai de nouveau tester votre formule elle marche mais quand je dépasse pas les 36heures j’ai tous de meme 6 heure supp a 125 qui s’affiche.

Bonjour,

Voici le fichier rectifié (cellules en rouge).
Mes formules étaient bonnes si on était en décimal or, quand on travaille sur du temps, il faut adapter les formules. En fait 24:00 en format h:m équivaut à 1 en format standard, 12 heures = 0,5, une heure égale 1/24 soit 0,041666666.
C’est à dire que si tu saisis 0,5 dans une cellule puis que tu la mets en format heure tu obtiendras 12:00:00.
Il faut donc absolument faire la conversion. C’est ce que je te propose dans le fichier joint.
1,5 égale 36 heures
test calcul nouveau format.xlsx (20,0 Ko) (20,0 Ko)
J’ai remis tes totaux hebdomadaires au format horaire (en supprimant le *24)

bonjour,

a ok j’avais oublier cette étape.

a par que je me suis tromper la tranche est de 37 à 43 et de 44 à 48
et du coup je me souvient pourquoi j’était sous se format de cellule. car a la fin de mon tableau je multiplie le nombre d’heure supp par son taux. et du coup sa ne marche plus avec le nouveau format de cellule [hh]:mmtest calcul nouveau format v2.xlsx (27,8 Ko)

je vous remercie beaucoup pour cet éclaircissement.

cordialement

Bonjour,

Voici une V3. Dans les formules, j’ai mis des fractions 37/24 ou 44/24 ou 48/24 pour signifier les limites hautes et basses.
Je pense que cela sera plus facile pour modifier.
J’ai intégré la limite haute de 48:00 mais cela a pour conséquence que les heures efectuées au-delà de 48 heures ne sont plus comptabilisées ??test calcul nouveau format v3.xlsx (26,1 Ko)

mais du coup il reste deux problèmes,

de 37 à 43 c’est égale a 7 et quand on dépasse les 43 le 7 se transforme en 6 voir le surlignage en vert.

et du coup au surlignage en jaune je ne peux plus faire mon calcul de horaire multipilier par un taux vu que les cellules on changer de forma.

je suis vraiement désolé de vous embéter avec cela.

cordialement
test calcul nouveau format v3.1.xlsx (26,3 Ko)

Bonjour,

Pour faire les calculs en euro, il faut repasser en système décimal et multiplier le résultat par 24 puis par le taux (1,25 pour 125% ou 1,5 pour 150%) puis le montant horaire.
Voici une nouvelle version.test calcul nouveau format v3.2.xlsx (26,0 Ko)

1 J'aime

un problème s’accroche, quand le compteur passe a 44 la donnée affiche toujours 0 et non 1 de 44>48 on devrai avoir des données de 1>5

Copie de test calcul nouveau format v3.2.xlsx (25,4 Ko)

Donc si je comprends bien,
c’est à partir de 36:01 que l’on passe en heure sup à 125% et à partir de 43:01 que l’on passe en heure sup à 150% ?
Si c’est le cas, je pense que tu peux rectifier :
Heures sup à 125% : =SI(ET(B18>36/24;B18<=43/24);B18-(36/24);SI(B18<=36/24;0;7/24))
Heures sup à 150% : =SI(B18<=43/24;0;SI(ET(B18>43/24;B18<=48/24);B18-(43/24);5/24))

non non les écart sin bon. c est juste que quand on passe à 44 heures la donnes à 150% affiché 0 mais elle devrai affiché 1. actuellement elle commence à compter à partir de 45 mais dans la formule on parle bien à partir de 44 jusqu a 48.

ça marche très bien merci beaucoup pour votre aide.

cordialement

Si 44 heures implique 1 heure supp à 150%, alors les minutes comprises entre 43:01 et 43:59 comptent 150%
De même que les minutes comprises entre 36:01 et 36:59 comptent 125%
Voici une dernière versionTest calcul nouveau format v3.3.xlsx (25,4 Ko)