Formule avec SI et Calcul


#1

Bonjour,

Je bute sur une formule Excel avec SI. Pourtant simple, mais rien à faire je n’obtiens pas le résultat escompté…

Pourriez-vous m’aider svp ?

Ci-joint le fichier.

En résumé, je souhaite la formule suivante :face_with_thermometer:

Si la colonne C indique un 2, alors tu ne fais rien, sinon fais le calcul : =SI(C6=2;"";B6*N6/1000).

Et vice versa, si la colonne C indique un 1, alors tu fais le calcul =SI(C6=2;"";B6*N6/1000), sinon tu ne fais rien.

Dans les deux cas, rien à faire, il m’indique un total dans les 2 colonnes, alors que pour la colonne O, je ne devrais “rien voir”, car “” et la colonne Q, OK pour le résultat.

J’ai également essayé de mettre un 0, c-a-d =SI(C6=2;0;B6*N6/1000) et cela ne fonctionne pas non plus.

Merci par avance pour votre aide,Class Doc.xlsx (11,9 Ko)

Bridget


#2

Bonjour @BRIDGET,

Voir correction des formules en:

En “O6” =SI(C6="2";"";B6*N6/1000)
En “Q6” =SI(F6="2";"";P6*E6/1000)

Fichier en retour ICI==> BRIDGET Class Doc.xlsx (13,5 Ko)

Cordialement.


#3

Bonjour,

Merci pour les corrections, et si je comprends bien, c’était simplement une histoire de “” sur le 2 ?

Mais au fait, pourquoi mettre 2 en “2” ? n’étant pas du texte…

Merci pour tes précisions.

Bridget


#4

Re @BRIDGET,

Si 2 et 1 sont écrits en format texte:

Parce que tu as mis cette formule en “C6” =SI(ESTVIDE(K6);"1";"2")
Et celle-ci en “F6” =SI(ESTVIDE(L6);"1";"2")

Voici pour la précision :wink:

Cordialement.


#5

Merci beaucoup! :smile::wink:


#6

@BRIDGET,

Pas de quoi :blush:

Si ton problème est résolu n’oublie pas de cliquer sur le petit :white_check_mark: sous la solution pour la valider.

Merci.