Fonction si et recherche v sur plusieurs colonnes

Bonjour,

Je souhaite savoir si des références données figure bien sur un fichier spécifique. Pour cela, j’ai utilisé la fonction SI ET RECHERCHE V mais sachant que les références peuvent être présentes sur une des 4 colonnes du fichier spécifique, je dois à chaque fois répéter la formule =SI(ESTNA(RECHERCHEV(A2;’[REFERENCES 4 COLONNES.xlsx]REFERENCES’!$A:$D;1;FAUX));“NON”;“OUI”) pour les 4 colonnes alors que j’aimerais bien avoir une formule qui prennent en compte les données de ces 4 colonnes en même temps.

Vous avez en pièce jointe deux fichiers (le fichier avec les quatres colonnes et le fichier avec les formules)REFERENCES 4 COLONNES.xlsx (9,3 Ko)

Merci.FICHIER AVEC FORMULE.xlsx (10,8 Ko)

Bonjour,

Voici ma proposition en utilisant la fonction EQUIV :
=SI(OU(NON(ESTNA(EQUIV(A2;A:A;0)));NON(ESTNA(EQUIV(A2;B:B;0)));NON(ESTNA(EQUIV(A2;C:C;0)));NON(ESTNA(EQUIV(A2;D:D;0))));“Oui”;“non”)