Fonction NB.SI.ENS


#1

Bonjour,

j’ai des cellules à comptabilisés, j’utilise la fonction NB.SI.ENS le soucis c’est que j’ai plusieurs critères à integrer mais une seule plage et je n’arrive pas à saisir la formule correctement.
par ex : j’ai une plage comprenant des données : 9h/RTT/8h/CA/FORM…
et je dois calculer le nombre de 8h et 9h que j’ai dans la même plage.

Merci pour votre aide


#2

Bonjour @grislaure,

Pas facile de répondre à ta question sans fichier représentatif, peux-tu nous joindre un fichier exemple ?

Pour joindre un fichier, suivre la procédure ci-dessous.

Joindre un fichier

@+
Cordialement.


#3

planning.xlsx (10,5 Ko)

du coup il me faudrait le nombre de 8h, de 9h, de 7h30 et de 11h par colonne.


#4

Re @grislaure,

Cool d’avoir mis un fichier :wink:, mais maintenant la grande question est :thinking::

Ou doivent-être les résultats ? En haut, en bas, sur la côté, dans une autre feuille… ?
Peux-tu répondre à cette question indispensable :wink:

Personnellement, je les mettrais en haut en dessous de la ligne “2” ce qui te permettrait de rajouter des données vers le bas de ta feuille, qu’en penses-tu ?

Voici une présentation possible, si cela convient, je t’explique tout:

grislaure planning V1.xlsx (14,2 Ko)

@+
Cdlt.


#5

Le but est de mettre le résultat en bas de chaque colonne.
Il est vrai que je m’exprime mal :grinning:
Donc pour récapituler il faudrait que j’ai en bas de chaque colonne le
nombre total de 7h30.8h.9h.11h.


#6

Re @grislaure,

Bon je viens de te répondre avant d’avoir vu ta réponse :blush:

Faut pas dire ça, il s’agit juste d’un manque de précision et pas un manque d’expression.

Voici une présentation en bas du tableau:

J’ai ajouté 2 colonnes “Valeur & Somme”

Puis en “B33”

=SOMME(C33:M33)&" Fois "&A33

Tirer vers le bas autant que nécessaire.

Et en bas de chaque colonne.

En “C33”

=NB.SI(C$3:C$31;$A33)

Tirer vers le bas et vers la droite autant que nécessaire.

Fichier ICI==> grislaure planning V2.xlsx (14,3 Ko)

Cordialement.


#7

Merci beaucoup pour ton aide. Je vais tester ça lundi matin. Bon week…