Filtre avancé et zone de critère

Bonjour,

J’utilise une macro pour effectuer un filtre avancé à partir d’une zone de critères. Celle-ci se remplit automatiquement selon les données entrées dans un formulaire grâce à une formule du type =SI(D6="";"";D6).

Mais lorsque je lance la macro, ça ne fonctionne pas…

Pourtant, lorsque j’écris directement dans la zone de critère à la place de la formule, ça marche. Le problème semble donc venir de la formule mais je n’arrive pas à comprendre pourquoi…

Merci d’avance pour votre aide !

Bonjour,

Sans fichier pour trouver le pourquoi du comment de la macro, je ne vois aucune solution :wink:

1 J'aime

bonjour @Chaton
voici un simple exemple

Sub test()
        If Range("D6").Value = "" Then
            Range("A1").Value = ""
        Else
            Range("A1").Value = Range("D6").Value
        End If
 End Sub

Bonjour,

Un exemple avec une formule dans la zone de critère et lancement par une macro.
Comme le dit Mimimathy, un exemple de fichier serait le bienvenu si tu n’arrives pas à résoudre le problème .Filtre avancé.xlsm (16,4 Ko)

1 J'aime

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.