FAQ: Formule SI une cellule contient un mot

Bonjour
Une question fréquemment posée sur Excel:

Comment detecter si une cellule contient un mot (avec une formule)
Par exemple : si le mot “abcd” apparait dans le contenu d’une cellule, alors on renvoie vrai, sinon on renvoie faux

wqrger abcd ceqf renverra vrai
qwertyuiop renverra faux

Avec une formule:
=SI(ESTNUM(CHERCHE("abcd";A1));VRAI;FAUX)

Fonctionnement:
On cherche le mot cible avec la formule CHERCHE dans la cellule A1. Si le mot est trouve, la fonction CHERCHE renvoie un nombre qui indique la position du mot.

On verifie donc que cette position est trouvee avec la fonction ESTNUM qui verifie que sont argument est un nombre,

Enfin on utilise une fonction SI pour afficher les resultats souhaites en cas de presenece on nom du mot recherche dans la cellule.

Bonsoir Docteur Excel,
peut-on rajouter à cette formule la recherche de plusieurs mots par ex “abcd” et “opqr” et quel est la formule à inscrire ?
Merci par avance Dr Excel !

Bonjour Tony_Singer,
Oui possible, il suffit de rajouter un opérateur logique OU / ET selon le besoin suivant la synthaxe :ET(Condition1;Condition2).

ce qui donne
ET(ESTNUM(CHERCHE(“abcd”;A1));ESTNUM(CHERCHE(“opqr”;A1)))

Ici dans ton cas la formule complete sera :
=SI(ET(ESTNUM(CHERCHE(“abcd”;A1));ESTNUM(CHERCHE(“opqr”;A1)));VRAI;FAUX)

1 J'aime