Facture automatisée


#1

Bonjour,

j’apprends à maîtriser les fonctions SI(), RECHERCHEV/H, CHOISIR().
Dans le fichier joint, j’ai besoin de comprendre comment faire afficher le montant de la remise (onglet Facture).
Merci !
Muwasa

2017 facture automatisée 04 septembre.xlsx (20,5 Ko)


#2

Hey Muwasa !

Je te propose ceci :arrow_right: 2017 facture automatisée 04 septembre.xlsx (20,8 Ko)

Quelques indications sont dans le fichier.
N’hésite pas si cela correspond pas à tes attentent, ou si tu désire autre chose…

Bye !
Louis


#3

Bonjour Louis,
Grand merci !
Je suis satisfait de la solution.
Bonne journée !
Muwasa


#4

Bonjour @Muwasa, @Louis,

Voici une autre proposition dans la feuille “Facture Bis”:

Déjà pour moi je laisserais la colonne “CODE” libre de choix avec des listes, pour cela voir dans le “Gestionnaire de noms”.

Puis dans “Validation des données”.

Validation des données

Puis en “B13” j’écrirais la formule comme ceci:

=SIERREUR(RECHERCHEV($A13;Tableau2;2;0);"")

Tirer jusqu’en “B24”.

En “D13”:

=SIERREUR(RECHERCHEV($A13;Tableau2;3;0);"")

Tirer jusqu’en “D24”

En “E13”

=SIERREUR(C13*D13;"")

Tirer jusqu’en “E24”

En “E25”

=SOMME(E13:E24)

En “B26”

="Remise"&" "&RECHERCHEH($E$25;Remise!$B$1:$F$2;2;1)*100&" %"

En “E26”

=INDEX(Remise!$B$2:$F$2;EQUIV($E$25;Remise!$B$1:$F$1;1))*$E$25

À la question “” comment faire pour ne pas afficher le signe € lorsque la cellule est vide ??? “”

J’ai appliqué un format personnalisé de “E13 à E29”

0,00 €;-0,00 €;

Ce qui permet d’avoir des chiffres positifs où négatifs avec le signe “€” sauf si la formule trouve 0

Ci-joint ton fichier en retour ICI==> Muwasa V1.xlsx (27,4 Ko)

Cordialement.


#5

Bonjour mdo 100,
Sincères remerciements. La solution proposée dépasse largement mon attente !
Muwasa