Est ce la bonne formule ?

Bonjour

Dans le fichier joint une zone de texte explique le problème rencontré.

Résumé de celui-ci : en utilisant la formule NB si ens cela ne rend pas le résultat escompté (une partie des critères étant située dans la même plage)

Peut-être que ce n’est pas la formule adaptée,ou la syntaxe incorrecte?

Merci de bien vouloir vous intéresser à ce cas

Bonne journée

Cordialement
Test_Ceiste-D.xlsx (11,7 Ko)

Bonjour @Ceiste,

En “D21”

=NB.SI.ENS($C$4:$C$17;$A$1;$E$4:$E$17;$C21)+NB.SI.ENS($C$4:$C$17;$A$3;$E$4:$E$17;$C21)+NB.SI.ENS($C$4:$C$17;$A$4;$E$4:$E$17;$C21)

Tirer vers le bas autant que nécessaire.

Cordialement.

Re @Ceiste,

Une autre proposition:

En “D21”

=SOMMEPROD((($C$4:$C$17=$A$1)+($C$4:$C$17=$A$3)+($C$4:$C$17=$A$4))*($E$4:$E$17=$C21))

Tirer vers le bas autant que nécessaire.

Cdlt.

Bonjour mdo 100

Parfait, cela à l’air tellement simple quand on regarde la solution,à mon niveau ce domaine reste perfectible.
Merci pour votre aide .
Bonne fin de journée

Cordialement

1 J'aime

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.