Différence d’heure

Bonjour,
Je cherche une solution à mon problème, dans un tableau Excel j’ai inscrit des heures sous ce format 12H00 et dans plusieurs case des horaires différentes
Je cherche à faire des calculs sur une dernière case permettant de calculer la différence du nombre d’heure
Exemple case1 … 12H00
case 2 … 19H15
Résultat case 3 … 7H15
Je cherche la formule qui me donnera le résultat dans la case 3
Merci de votre aide …

Bonjour,
si les heures sont dans les cellules C2 et B2 (soit 19H15 et 12H00)

=TEMPS(GAUCHE(C2;2);DROITE(C2;2);)-TEMPS(GAUCHE(B2;2);DROITE(B2;2);)

et mettre sous le format hh:mm

1 J'aime

bonjour

si case 1 par exemple B2 12:00
case C2 19:15 alors simplement en D2 la formule =SOMME(C2-B2) ce qui donne 07:15

Ouyououille :star_struck:
Là c’est du lourd
Bon Taz,
1- je pense que si les heures avaient été au format normal, la question n’aurait pas eu lieu, là, ce sont des heures 12H00 et non 12:10
2- ta formule, même si les cellules étaient au bon format ne peut pas fonctionner
3 - la fonction SOMME(), est en plus inutile (=C2-B2)

2 J'aimes

heu oui me suis trompé dans l’ordre c’est =C2-B2

et au format heures ça fonctionneheures.xlsx (8,0 Ko)

si je comprends bien dans ta formule tu isoles les nombres pour les soustraire apres !

Bonsoir @taz067, @Pagliced,
Salut l’ami @Mimimathy,

@taz067, la Syntaxe de la fonction “TEMPS” est:

=TEMPS(heure; minute; seconde) on peut supprimer seconde par un ; cela devient =TEMPS(heure; minute;)

Quand en “B2 et C2” on écrit 12H00 et 19H15 c’est du TEXTE

Donc 12H00 =TEMPS(GAUCHE(B2;2);DROITE(B2;2);) devient au format numérique 12:00
Et 19H15 =TEMPS(GAUCHE(C2;2);DROITE(C2;2);) devient au format numérique 19:15

Il suffit alors d’appliquer la formule:

=TEMPS(GAUCHE(C2;2);DROITE(C2;2);)-TEMPS(GAUCHE(B2;2);DROITE(B2;2);) pour obtenir 7:15 au format de cellule hh:mm

On peut aussi procéder autrement avec un format de cellule.

Cette méthode permet d’écrire 12:00 et la transformation se fait directement en 12 H 00.

Ce qui permet alors d’utiliser la formule =C2-B2

Capture

Voir fichier exemple ICI==> heures.xlsx (10,7 Ko)

Cordialement.

2 J'aimes

Merci à tous pour vos réponse … j’ai réussi grâce à vous à faire ce que je voulais

Par contre je cherche maintenant la solution pour changer de couleur les cases qui afficheront 12 H 00 … en vert
Et 07 H 00 … en rouge

Pouvez vous me donner encore un petit coup de main
Cordialement

Vous êtes au top

Bonjour,

Pour être encore plus au TOP,
un p’tit classeur serait préférable, pour savoir où aller “piocher” :wink:

@mdo100 merci pour cette explication eclairé.

Bonjour

Si ton problème est résolu, peux-tu stp cocher le petit :white_check_mark: sous le message qui contient la solution stp?

Cela nous aide à déterminer qui a encore besoin d’aide et qui est sauvé!

Merci