Création d'une formule


#1

N° NOMS T7 oct-17
Bonjour,

Je cherche une formule afin qu’automatiquement je puisse trouver le pourcentage des personnes qui ont déposé leur document:

  • Dans la colonne des croix (X) : c’est ceux qui ont déposé leur document
  • Dans la colonne des croix, le vide représente des cases rouge: C’est ceux qui n’ont pas déposé leur document. Je voudrai mettre une formule qui me donnera automatiquement le pourcentage des croix au fur et à mesure que je marque les croix par rapport au nombre de personnel.
    1 AB A X
    2 AC B X
    3 AD A X
    4 AC B X
    5 AD A
    6 AC B X
    7 AD A X
    8 AC B
    9 AD A X
    10 AC B X
    11 AD A X
    12 AC B
    13 AD A X
    14 AC B X
    15 AD A X
    16 AC B X
    17 AD A X
    18 AC B X
    19 AD A X
    20 AC B X
    21 AD A X
    22 AC B X
    23 AD A X
    24 AC B X
    25 AD A X
    26 AC B X
    27 AD A X
    28 AC B X
    29 AD A X
    30 AC B X
    31 AD A X
    32 AC B
    33 AD A X
    34 AC B X
    35 AD A X
    36 AC B X
    37 AD A X
    38 AC B X
    39 AD A X
    40 AC B X
    41 AD A X
    42 AC B X
    43 AD A X
    44 AC B X
    45 AD A X
    46 AC B X
    47 AD A X
    48 AC B X
    49 AD A X
    50 AC B X
    51 AD A X
    52 AC B X
    53 AD A X
    54 AC B
    55 AD A X
    56 AC B X
    57 AD A X
    58 AC B X
    59 AD A X
    60 AC B
    61 AD A X
    62 AC B X
    63 AD A X
    64 AC B X
    65 AD A X
    66 AC B X
    67 AD A
    68 AC B X
    69 AD A X
    70 AC B X
    71 AD A
    72 AC B X
    73 AD A X
    74 AC B X
    75 AD A X
    76 AC B X
    77 AD A X
    78 AC B X
    79 AD A X
    80 AC B X
    81 AD A X
    82 AC B X
    83 AD A X
    84 AC B X
    85 AD A X
    86 AC B X
    87 AD A X
    88 AC B X
    89 AD A X
    90 AC B X
    91 AD A X
    92 AC B X
    93 AD A X
    94 AC B
    95 AD A X
    96 AC B X
    97 AD A X
    98 AC B X
    99 AD A MATERNITE
    100 AC B X
    101 AD A X
    102 AC B
    103 AD A X
    104 AC B X
    105 AD A X
    106 AC B X
    107 AD A X
    108 AC B X
    109 AD A X
    110 AC B X
    111 AD A X
    112 AC B X
    113 AD A X
    114 AC B X
    115 AD A X
    116 AC B
    117 AD A X
    118 AC B X
    119 AD A X
    120 AC B X
    121 AD A X
    122 AC B X
    123 AD A
    124 AC B X
    125 AD A X
    126 AC B X
    127 AD A X
    128 AC B X
    129 AD A X
    130 AC B X
    131 AD A X
    132 AC B X
    133 AD A X
    134 AC B X

#2

Bonjour @candys,

Peux-tu nous fournir un fichier au format Excel ?

@+


#3

Re @candys,

Malgré l’absence de fichier, je te fait une proposition dans le fichier que j’ai du créer.

Et comme tu ne précises pas les colonnes, alors je commence à la colonne “A”.

Donc première chose a faire et de concaténer la colonne “B” (NOMS) et la colonne “C” (T7). dans la colonne “E”.
En “E2”:

=B2&C2

Tirer vers le bas autant que nécessaire.
La colonne “E” peut-être masquée si besoin.

Puis dans la colonne “F”.
En “F2”:

=NB.SI(E$2:E2;$E2)/NB.SI($D$2:$D$135;"X")

Colonne a mettre au format % et tirer vers le bas autant que nécessaire.

Ci-joint le fichier ICI==> candys V1.xlsx (19,0 Ko)

Cordialement.


#4

Bonjour Monsieur,

Je vous envoie en pièce jointe le fichier n question.

Merci

Amy

MAN TIME SHEET FY 18 OCT 2017.xlsx (23 KB)


#5

Bonjour @candys,

Qu’est-ce qui ne va pas dans le fichier que j’ai fourni lors de ma 2ème réponses ?

Sinon ou doivent se situer les résultats, dans quelles colonnes ou cellules ?
Reformuler une demande plus précise ?

Ou bien alors voir les formules dans les cellules “F6 à Q6”

=SIERREUR(NB.SI(F$8:F$141;"X")/NBVAL($B8:$B141);"")

Fichier ICI==> candys V2 MAN TIME SHEET FY 18 OCT 2017.xlsx (25,8 Ko)

Cordialement.


#6

Je vous renvoie le document avec les explication dans la colonne et la case
où la formule doit être.

Merci

Amy

MAN TIME SHEET FY 18 OCT 2017.xlsx (23.2 KB)


#7

Re @candys,

Je ne ferais pas de commentaire :thinking:

candys V3 MAN TIME SHEET FY 18 OCT 2017.xlsx (25,9 Ko)

Bonne soirée.


#8

Parfait. C’est exactement cette formule que je voulais. Je vous remercie
infiniment.

Bien à vous

Amy