Convertir un format numérique en format DATE


#1

Comment remplacer le résultat d’un division (ex: 25/12) par un format du type = “2 ans et 1 mois” ?


#2

Bonjour tankifil, toutes et tous,

Voir fichier ci-joint.

tankifil V1.xlsx (9,5 Ko)

Cela convient-il ?

Cordialement.


#3

Bonjour

Comme suggéré par @mdo100

  • Utiliser la formule ENT pour obtenir la partie entière de la division =ENT(A4/12)
  • Utiliser la formule MOD pour obtenir le reste (nombre de mois) =MOD(A4,12)
  • Combiner le tout avec le symbole & qui permet de concatener les chaines de caractères


#4

Bonsoir DocteurExcel, tankifil,

Effectivement, je ne suis pas très pédagogue :wink: de plus il y avait une coquille dans ma formule, heureusement soignée par le Docteur :eyes:.

Alors je vais à mon tour améliorer la formule, car si en “A2” = 12 alors on obtient 1 an et 0 mois (an sans S à la fin).
Dans ce cas la formule est:
=SI(ENT(A2/12)<2;ENT(A2/12)&" an et “&MOD(A2;12)&” mois";ENT(A2/12)&" ans et “&MOD(A2;12)&” mois")

Cdlt.

PS: DocteurExcel, comment joindre une image de démonstration comme tu as fait dans ton message.


#5

@mdo100 il suffit de faire un glisser déposer de ton image vers le champ d’écriture de message, sinon tu peux aussi l’uploader avec le bouton “Joindre un fichier”


#6

Ok, merci pour l’info, je viens à l’instant de répondre à elhechmi_Elad, et donc de me servir de tes conseils avisés.:grinning:
Et merci pour le j’aime concernant " Masquer des colonnes sous conditions ".

Bonne fin de soirée :zzz:


#7

@tankifil la réponse te convient-elle? Si c’est le cas merci de cocher le :white_check_mark: en dessous de la réponse pour marquer ton problème comme résolu