Connaitre la meilleure série de bons résultats dans un tableau


#1

bonjour, j’ai rempli un tableau de 16 000 lignes qui indique pour chaque
ligne un nom de participant, un résultat (vrai ou faux); un gain et la date
du jour où le participant a joué.
Je souhaite pour chaque participant connaître la meilleure série de bon
résultat.

Exemple:
le joueur A a connu une série de 13 résultats Vrai d’affilé. Le joueur B a
connu une série de 8 résultats Vrai d’affilé.

Je voudrais que dans mon tableau qui résume les meilleurs perf de chaque
joueurs, puisse apparaitre cette statistique.
Pouvez-vous m’aider?

Alain

Alain ANSART


#2

#3

Bonjour!

Je ne suis pas sur d’avoir bien compris ta question.
Pourrais tu nous donner plus de détails stp et si possible inclure un fichier d’exemple?

Merci et à bientôt


#4

Bonsoir,

Supposons que je souhaite analyser les résultats d’un joueur de tennis sur
10 années.
Une colonne de ce tableau comportera soit “V” pour victoire soit “D” pour
défaite.

Supposons qu’il y a des centaines de résultats de matchs, comment connaître
les meilleures séries de victoires/défaite?
Si on regarde ci dessous, ce qui pourrait ressembler aux données de cette
colonne (verticalement biensûr)

vdvvvdddvdvdvdvdvdddvdvdvdvddvvvvddvvdvdddvvvvvvdddvdvdvdvdvddvvvvvvvvdddddvvvvdddvvvvvvvvvvvvvddddddvvddvdvdvdvdddvdvvvvvdddddvvvdvdvdv

Comment à l’aide d’une formule pouvez vous me dire que la + importante
série de victoire est de 13 et 6 pour les défaites?
Comment à l’aide d’une formule vous pourrez me dire qu’elle série de
victoire est la + fréquente ?
S’il y a plusieurs joueurs, quelle formule pourrait me dire lequel enchaine
le + de série de 5 victoires minimum?

Merci pour votre aide

Alain

Alain ANSART

Mobile/Whatsapp: +33 620 272 368
Wechat ID: alainansart


#5

Hello
Je te propose les formules suivantes:
Victoires consécutives à chaque match: =SI(ET(A3;A2);B2+1;--A3)
Si on a une victoire et que le match précédent était aussi une victoire, on rajoute 1 au compteur de victoires. Sinon on affiche 1 pour victoire, 0 pour défaite

28

Pour avoir uniquement un nombre de victoires par série: =SI(ET(B4=0;B3<>0);B3;0)
Si le prochain match est une défaite mais le match actuel est une victoire, c’est la fin d’une série et on affiche alors le nombre de victoire qui est maximum en fin de série. Sinon on affiche zéro.

39


#6

Merci beaucoup pour votre aide, j’ai du cependant créé 4 nouvelles colonnes
pour avoir ces résultats dans mon tableau mais les résultats sont là!

à bientôt

Alain

Alain ANSART

Mobile/Whatsapp: +33 620 272 368
Wechat ID: alainansart


#7

Content de voir ton problème est résolu!

Pourrais-tu nous partager la solution complète ici stp?
Comme ca si quelqu’un tombe sur un problème similaire il aura accès à la solution

A bientôt