Compter sans doublons

Bonjour,
Je sollicite votre aide pour mon problème dans le fichier joint.
Merci d’avance,
=> compter sans doublons.xlsx (8,4 Ko)

Bonjour @panda,

A tester:

Sans cellule vide

=SOMMEPROD(1/NB.SI(C3:C14;C3:C14))

Si cellule vide

=SOMMEPROD(SI(C3:C14<>"";1/NB.SI(C3:C14;C3:C14)))

Formule matricielle a valider avec ctrl + maj + entrée

Cordialement.

Bonjour mdo100,
c’est parfait, ça marche.
Mais j’ai une question, est-ce que cette formule fonctionne avec NB SI car il y a quelques conditions ou bien il vaut mieux que le fichier vous soit envoyé?
Merci à vous

Re @panda,

J’ai répondu avec les éléments qu’ils y avaient dans le fichier joint, si il y a des conditions supplémentaires, elles n’étaient pas dans le fichier.

Donc un nouveau fichier est nécessaire avec les nouvelles explications.

@+

Bonjour mdo100,
Ci-joint alors le fichier pour ma question d’hier.
Merci à vous!
=> compter sans doublons.xlsx (11,5 Ko)

Bonjour @panda,

Voici une proposition a tester:

En “D39”

=NB(1/FREQUENCE(SI(($C$20:$C$34=$C39);EQUIV($J$20:$J$34;$J$20:$J$34;0));LIGNE(INDIRECT("1:"&LIGNES($J$20:$J$34)))))

Formule matricielle a valider avec ctrl + maj + entrée

Fichier de retour ICI==> Compter sans doublons.xlsx (12,0 Ko)

Cordialement.

Re,
Je t’envoie mon fichier car je n’y arrive pas.
Merci

=> Compter sans doublon 2.xlsx (13,5 Ko)

Re @panda,

Et si tu avais mis le bon fichier depuis le début :exclamation:

Alors selon les nouvelles conditions du dernier fichier joint, voici une nouvelle proposition à tester:

Dans l’onglet "option autorisé"

En "F5"

=NB(1/FREQUENCE(SI((source!$C$8:$C$25=2)*(source!$AA$8:$AA$25<5000000);EQUIV(source!$J$8:$J$25;source!$J$8:$J$25;0));LIGNE(INDIRECT("1:"&LIGNES(source!$J$8:$J$25)))))

Formule matricielle a valider avec ctrl + maj + entrée

En "F7"

=NB(1/FREQUENCE(SI((source!$C$8:$C$25=2)*(source!$AA$8:$AA$25>15000000);EQUIV(source!$J$8:$J$25;source!$J$8:$J$25;0));LIGNE(INDIRECT("1:"&LIGNES(source!$J$8:$J$25)))))

Formule matricielle a valider avec ctrl + maj + entrée

Cdlt.

1 J'aime

Re,
C’est d’accord, je vais tester
Merci

Bonjour mdo100,
J’ai testé le fichier et ça marche mais au lieu d’avoir le résultat comme 12, on a 10. Il y a 12 intitulé en supprimant les doublons et les montants sont tous < 5 000 000.
Merci à vous

Bonjour @panda,

Met tes :eyeglasses: et ouvre les :eyes:

Le reste des lignes étant ou des doublons colonne “J” ou ne répondant pas au critère 2 dans la colonne “C”.

Cordialement.

1 J'aime

Re,
Oui mais RAZAFIARIMANANA MADELEINE et RAKOTOARISOA n’ont pas de doublons donc parmi ceux à compter.
MErci

Re @panda,

Dans ton fichier tu voulais que la clé agence soit égal à 2.
Si tu regarde bien tu peux voir que pour:

RAZAFIARIMANANA MADELEINE la clé agence est 3
RAKOTOARISOA la clé agence est 8

Cdlt.

1 J'aime

Re,
Ah oui, c’est vrai.
Merci pour le temps que tu a consacré pour moi.
Cordialement,

1 J'aime

Re @panda,

De rien, au plaisir.

Bonne journée.

Re,
Est-ce que si je modifie la plage $25 en $45000, y a t-il un impact sur formule?
Merci

Re @panda,

Dans ce cas il faut aussi changer les autres plages.

=NB(1/FREQUENCE(SI((source!$C$8:$C$45000=2)*(source!$AA$8:$AA$45000<5000000);EQUIV(source!$J$8:$J$45000;source!$J$8:$J$45000;0));LIGNE(INDIRECT("1:"&LIGNES(source!$J$8:$J$45000)))))

Formule matricielle a valider avec ctrl + maj + entrée

Cdlt.

Re,
Et si les valeurs des colonnes C de l’onglet source sont des formules, cela affecte t-il le résultat?
Merci

Bonjour mdo,
La formule marche bien. Mais actuellement, il faut ajouter une condition, la première était <5 000 000Ar et il y ajouter >0(colonne concernée = AA).
Pourriez-vous modifier la formule s’il vous plaît?
Merci à vous!

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.